locked
Visual Studio Community:Sign in does not work. RRS feed

  • Question

  • When I open visual studio community I get the message that wants me to sign in to microsft account. When I press the sign in button I get the following message:Sorry, we run into a problem. SP324095: Our service was unable to complete the request.

    I am trying to fix that but I canot. Can someone help me with this issue?

    Monday, March 14, 2016 4:54 PM

Answers

  • Hi Tasos_Cap,

    Which version of Visual Studio Community do you want to sign in? If it is Visual Studio Community 2015, please check your IE version first. It should be version 11.

    Then please make sure whether you have added live.com and Microsoft.com to trusted sites in your IE settings. And please try access this site https://app.vssps.visualstudio.com here we can see if your account works. If you cannot access the above site please create a new account to have a try.

    In addition, please check whether your IE have enabled the javascript features with following steps.

    • Start Internet Explorer, press Alt to reveal the Menu bar, click Tools, and then click Internet Options.
    • Click the Security tab, and then click the Internet zone.
    • Depending on whether you have to customize your Internet security settings, select one of the following options:
      • If you do not have to customize your Internet security settings, click Default Level.
      • If you have to customize your Internet security settings, click Custom level, scroll down to the Active scripting section, and then click Enable.

    Best Regards,
    Weiwei

    • Proposed as answer by Weiwei Cai Wednesday, March 16, 2016 9:38 AM
    • Marked as answer by Tasos_Cap Thursday, March 17, 2016 4:08 PM
    • Unmarked as answer by Tasos_Cap Thursday, March 17, 2016 4:08 PM
    • Unproposed as answer by Tasos_Cap Thursday, March 17, 2016 4:08 PM
    • Marked as answer by Tasos_Cap Thursday, March 17, 2016 8:41 PM
    Tuesday, March 15, 2016 6:13 AM

All replies

  • Hi Tasos_Cap,

    Which version of Visual Studio Community do you want to sign in? If it is Visual Studio Community 2015, please check your IE version first. It should be version 11.

    Then please make sure whether you have added live.com and Microsoft.com to trusted sites in your IE settings. And please try access this site https://app.vssps.visualstudio.com here we can see if your account works. If you cannot access the above site please create a new account to have a try.

    In addition, please check whether your IE have enabled the javascript features with following steps.

    • Start Internet Explorer, press Alt to reveal the Menu bar, click Tools, and then click Internet Options.
    • Click the Security tab, and then click the Internet zone.
    • Depending on whether you have to customize your Internet security settings, select one of the following options:
      • If you do not have to customize your Internet security settings, click Default Level.
      • If you have to customize your Internet security settings, click Custom level, scroll down to the Active scripting section, and then click Enable.

    Best Regards,
    Weiwei

    • Proposed as answer by Weiwei Cai Wednesday, March 16, 2016 9:38 AM
    • Marked as answer by Tasos_Cap Thursday, March 17, 2016 4:08 PM
    • Unmarked as answer by Tasos_Cap Thursday, March 17, 2016 4:08 PM
    • Unproposed as answer by Tasos_Cap Thursday, March 17, 2016 4:08 PM
    • Marked as answer by Tasos_Cap Thursday, March 17, 2016 8:41 PM
    Tuesday, March 15, 2016 6:13 AM
  • Well, the version of the visual studio community is the one of 2015. I have read about this issue and said the same thing, which is to enable JavaScript. I did that but nothing better happened. I tried the link above in order to connect to my microsoft account and it works properly. The main problem is that when I open the application I get the above message and I cannot do anything. Also I pressed the "Add an account..." button and when I wrote my account, it showed me a message saying that my Internet Explorer is not in the latest version, but I downloaded that and nothing changed. I want to use the Visual Studio app and I cannot do that. Please answer me as soon as possible.
    Thursday, March 17, 2016 8:43 PM
  • Hi Tasos_Cap,

    >>Also I pressed the "Add an account..." button and when I wrote my account, it showed me a message saying that my Internet Explorer is not in the latest version, but I downloaded that and nothing changed.

    Please check your IE version from Tools -> About Internet Explorer from right-top of IE, whether it has upgraded successful. And after upgrading, please restart your IE and Visual Studio to make sure the update has start working.

    And sometimes the issue is caused by the DNS Settings .Please try to flushing your DNS with the command "ipconfig/flushdns" at the command prompt to see if it helps.

    If still can't sign, please sign with another way to sign Visual Studio automatically from Visual Studio Online.

    1. Login Visual Studio Online with your Microsoft account.
    2. Click "Open in Visual Studio" hyperlink in right-side of the site.
    3. The Visual Studio will be opened and sign with your Microsoft Account automatically.

    Best Regards,
    Weiwei

    Friday, March 18, 2016 1:45 AM
  • I did the last thing you said but it sawed a message saying:

    TF30063: You are not authorized to access https://tasoscap.visualstudio.com/defaultcollection

    What am I supposed to do?

    Saturday, March 19, 2016 6:03 PM
  • Hi Tasos_Cap,

    According to the error message, the problem is more related to your Microsoft account.

    Please sign up a new Microsoft account and then re-sign in to your Visual Studio again to check whether it can sign in now.

    Best Regards,
    Weiwei

    Monday, March 21, 2016 2:07 AM