none
Verification Token is Empty RRS feed

  • Question


  • I have two Apps for Office that just stopped working today because when I submit a token for verification all I get in return is:

    <?xml version="1.0"?>
    
    -<VerifyEntitlementTokenResponse xmlns:i="http://www.w3.org/2001/XMLSchema-instance" xmlns="http://schemas.datacontract.org/2004/07/Microsoft.Office.Web.OfficeMarketplace.Verification.Service.Contract">
    
    <AssetId i:nil="true"/>
    
    <DeploymentId i:nil="true"/>
    
    <EntitlementAcquisitionDate>0001-01-01T00:00:00</EntitlementAcquisitionDate>
    
    <EntitlementExpiryDate i:nil="true"/>
    
    <EntitlementType i:nil="true"/>
    
    <IsEntitlementExpired>false</IsEntitlementExpired>
    
    <IsExpired>false</IsExpired>
    
    <IsSiteLicense>false</IsSiteLicense>
    
    <IsTest>false</IsTest>
    
    <IsValid>false</IsValid>
    
    <ProductId i:nil="true"/>
    
    <Seats>0</Seats>
    
    <SignInDate>0001-01-01T00:00:00</SignInDate>
    
    <SubscriptionState i:nil="true"/>
    
    <TokenExpiryDate>0001-01-01T00:00:00</TokenExpiryDate>
    
    <UserId i:nil="true"/>
    
    </VerifyEntitlementTokenResponse>

    Is there a reason why the REST service:

    https://verificationservice.officeapps.live.com/ova/verificationagent.svc/rest/verify?token={token}

    just stopped working. Is Microsoft having a problem with this service?

    Thursday, June 11, 2015 11:56 PM

All replies

  • The problem was fixed by removing and then adding again the service reference:

     https://verificationservice.officeapps.live.com/ova/verificationagent.svc.

    It is strange that two independent apps would both have the verification stop at the same time.

    Does anyone have any ideas?

    Friday, June 12, 2015 6:13 PM
  • The two apps just stopped verifying again. Reinstalling VerificationSvc namespace fixed it again.

    What is going on here? The apps have worked with no problems for many months and nothing has changed on my end. 

    Friday, June 12, 2015 8:45 PM
  • Hi BtandbZ,

    This forum is to ask questions and comment about developing apps for Office 2013, your issue is more related with publishing apps for the Office Store, I will move this thread to the more related forum.

    Reference: https://social.msdn.microsoft.com/Forums/officeapps/en-US/home?forum=officestore

    Thanks for your understanding.

    Best Regards,

    Edward


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.


    Monday, June 15, 2015 8:38 AM
  • Same problem same fix.

    I do not understand why this question was moved. There is no problem publishing the app, the problem is that the VerificationSVc namespace starts to return an empty token after working for a while.

    Wednesday, June 17, 2015 4:37 PM