locked
VS2010 source editor performance RRS feed

  • Question

  • Hi,

    Just a bit of history, I have experience with VS2002, VS2005 and VS2008 and about three weeks ago I installed Visual Studio 2010 Ultimate on my laptop. VS2010 is connected to TFS if that matters.

    So far my experience of VS2010 is unfortunately a bit negative. The source code editor seems to be very slow and it freezes up for a period of a few seconds up to maybe 15-20 seconds which is extremely irritating. It appear that if I quickly open a few source files and make some rapid changes the editor needs quiet a bit of time to process these actions. Whenever this happens a small animation is shown in the bottom area of the visual studio window, to the left of where visual studio show the current line number (for instance "Ln 30"). In the above case, I am only viewing and changing code, not compiling.

    What sort of processing does visual studio perform in the above mentioned case? Do I have any options to turn off any features used by editor that require a lot of CPU?

    Using Windows XP with SP3 and DirectX 9.0c installed.

    The laptop uses 2.8 GHz processor, 2GBmemory, more than 200GB of free space on hard disk.

     

    Friday, November 12, 2010 2:53 PM

Answers

  • Hello,

    You can first try the following steps to see if they help:

    a)     Try to run devenv /ResetSettings (in command prompt) to eliminate the related potential settings problem.

    b)     Try disabling Add-ins (e.g. “Tools” | “Add-in Manager”) or run “devenv.exe /SafeMode”.This can eliminate the possibility that third party Add-ins or packages are causing problems. (For more detailed VS command line switches information, see: http://msdn2.microsoft.com/en-us/library/xee0c8y7.aspx )

    In adition, I have ever had a machine which has 2GB memory, VS2010 does not work very smoothly on it, after upgrading to 4GB, it works very well.

    Thanks.


    Please remember to mark the replies as answers if they help and unmark them if they provide no help

    • Marked as answer by Edwer Fang Thursday, November 18, 2010 3:06 AM
    Monday, November 15, 2010 6:11 AM