locked
Visual Studio locks when bringing up "Run Unit Test" vs2013 RRS feed

  • Question

  • 2013 Visual studio 2013.

    I had been running a few simple unit tests on a large project.   Then 2013 stopped responding and said  -- please contact Microsoft.

    most time the test explore never comes up.  I tried the test with a tiny project .  still same issue

    this is my tiny project

     Using System.Configuration;
    using Microsoft.VisualStudio.TestTools.UnitTesting;

    namespace UnitTestProject1
    {
        [TestClass]
        public class UnitTest1
        {
            [TestMethod]
            public void TestMethod1()
            {
                Assert.AreEqual(1,1);
            }

            [TestMethod]
            public void TestMethod2()
            {
                Assert.AreEqual(2, 1);
            }
        }
    }


    Howard Davis

    Monday, March 23, 2015 10:26 PM

Answers

  • Hi Howard Davis,

    Could you tell us the real VS2013 version you were using? We have to make sure that it supports the unit test project.

    >>most time the test explore never comes up.  I tried the test with a tiny project .  still same issue

    We could open the test explorer window under Test menu->Windows.

    Before you run your test, please clean and rebuild your test project, and make sure no any warning or error, and then run it from the test explorer window, check the result.

    In addition, you would check your task manager, and make sure that it is free before you run your tests. I mean that we have to make sure that it is not the performance issue.

    But if a simple Assert method still doesn't work in your side, I doubt that it is your VS IDE issue.

    Run your VS as the admin, check the result.

    If possible, please repair your VS, please also install the VS2013 update 4, and then create a new test project, check the result.

    Best Regards,

    Jack


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.


    Tuesday, March 24, 2015 7:25 AM