locked
Are there known problems with 8.1 MediaCapture InitializeAsync? RRS feed

  • Question

  • My Lumia 920 keeps needing to be soft reset with volume down and power for 15 seconds, as it randomly completely locks up while debugging.

    I'm awaiting MediaCapture.IntializeAsync followed by awaiting MediaCapture.StartPreviewAsync

    I'm running the developer preview version.  Anyone else run against this, or got it to work successfully?

    If it's of any help, occasionally the phone gets into a state where InitializeAsync throws an exception with Hresult 0xE8010014

    My initialization CapSettings are:

    capSettings

    {Windows.Media.Capture.MediaCaptureInitializationSettings}

        AudioDeviceId: ""

        AudioProcessing: Default

        AudioSource: null

        MediaCategory: Other

        PhotoCaptureSource: Auto

        StreamingCaptureMode: Video

        VideoDeviceId: "\\\\?\\DISPLAY#QCOM_AVStream#3&2e24c17&0&UID32768#{e5323777-f976-4f5b-9b55-b94699c46e44}\\Front Sensor"

        VideoSource: null


    Anthony Wieser | Wieser Software Ltd | www.wieser-software.com


    Monday, June 2, 2014 4:04 PM

All replies

  • Further to the original post, latest WP8.1 preview now installed, and the problem still exists.
    The program is particularly prone to locking up the entire phone when re-initializing.

    I've never managed to lock it up when the preview wasn't being used.

    Is it necessary to wait for the preview to be initialized before making it visible?


    Anthony Wieser | Wieser Software Ltd | www.wieser-software.com

    Monday, June 2, 2014 8:40 PM