none
Version conflict detected for Microsoft.IdentityModel.Clients.ActiveDirectory RRS feed

  • Question

  • Creating an Azure function that uses nuget packages Microsoft.Rest.ClientRuntime.Azure.Authentication for authenticating to DataLake as well as Microsoft.IdentityModel.Clients.ActiveDirectory for authenticating to HDInsight. Getting the following error when I try to install both in the function project:

    uninstall-package : Version conflict detected for Microsoft.IdentityModel.Clients.ActiveDirectory. Reference the package directly from the project to resolve this issue. MyProject.Functions (>= 1.0.0) -> Microsoft.Rest.ClientRuntime.Azure.Authentication (>= 2.3.1) -> Microsoft.IdentityModel.Clients.ActiveDirectory (>= 2.28.3) MyProject.Functions (>= 1.0.0) -> Microsoft.Azure.Common.Authentication (>= 1.7.0-preview) -> Microsoft.IdentityModel.Clients.ActiveDirectory (>=2.18.206251556).

    It looks like Microsoft.Azure.Common.Authentication 1.7.0-preview has a constraint on referencing Microsoft.IdentityModel.Clients.ActiveDirectory 2.18.206251556 only. Unfortunately this library has not been updated since February 2016 and I'm not sure of another way of authenticating non-interactively with HDInsight besides the steps outlined at https://docs.microsoft.com/en-us/azure/hdinsight/hdinsight-create-non-interactive-authentication-dotnet-applications

    Thursday, November 9, 2017 3:04 AM