locked
How do I fix 'deployment errors' ? RRS feed

  • Question

  • User360634 posted

    I'm running a fresh install of Visual Studio 2017 with Xamarin with my Android SDK fully updated as well as the NuGet Packages. I have my Android phone connected with USB debugging enabled and the ADB recognizing it properly, and visual studio recognizing it, when wanting to debug. I've created a blank Xamarin forms app and when trying to run it on my Android phone, the build succeeds but the deployment fails, giving the pop-up "There were deployment errors. Continue?"

    Tuesday, November 28, 2017 11:11 AM

Answers

  • User360634 posted

    I was able to solve the problem by unchecking "use shared runtime" in the android options of the project

    • Marked as answer by Anonymous Thursday, June 3, 2021 12:00 AM
    Tuesday, November 28, 2017 12:45 PM

All replies

  • User360731 posted

    Try to deploy a blank page and go one by one. I had the same issue then found that there were spelling mistakes...

    Tuesday, November 28, 2017 12:08 PM
  • User360634 posted

    I was able to solve the problem by unchecking "use shared runtime" in the android options of the project

    • Marked as answer by Anonymous Thursday, June 3, 2021 12:00 AM
    Tuesday, November 28, 2017 12:45 PM
  • User12817 posted

    Can you please provide a diagnostic build output and any logs from the Output pane when attempting to Deploy?

    Saturday, December 2, 2017 8:17 PM
  • User75888 posted

    Hi, In my case the Keystore path was wrong, deployed successful after fixing the path.

    Friday, June 22, 2018 10:39 AM
  • User387844 posted

    @HoodHook said: I was able to solve the problem by unchecking "use shared runtime" in the android options of the project

    i am also unchecked but not solved. any query

    Tuesday, August 13, 2019 5:06 AM