none
Issue Listen shape with correlation. RRS feed

  • Question

  • Hello All,

    I am receiving and  correlating on two different messages with Listen shape as shown above.

    I am initializing correlation on first receive shape (Activate =true) and under listen shape i kept another receive shape (Activate=false) with following the correlation, I kept delay shape within listen for throwing error in case the file don't receive on second receive shape in time specified.

    I am getting error message while I am building the solution saying 

    In a sequential convoy the messagetypes must be identical unless the port is marked for OrderedDelivery.

    please help me to solve this and also tell me how the sequential convoy works.

    Thanks.

    Saturday, October 17, 2015 9:10 AM

Answers

  • Sequential Convoy:

    Initial Correlation and following Correlation from the same Logical Port (as in your diagram). If you are not using the same Operation (Port Type), which you are not, the Port must be marked Ordered Delivery, since the order of the messages becomes important and the first and second message received are not the same.

    So your solution should (not 100% sure, since I don't know exactly what you are trying to accomplish, a parallel convoy might also be an option) be to set "Ordered Delivery" to True on your Receive Port (Port_1).

    Morten la Cour


    • Marked as answer by _NiLeSh Saturday, October 17, 2015 10:35 AM
    Saturday, October 17, 2015 9:40 AM

All replies

  • Sequential Convoy:

    Initial Correlation and following Correlation from the same Logical Port (as in your diagram). If you are not using the same Operation (Port Type), which you are not, the Port must be marked Ordered Delivery, since the order of the messages becomes important and the first and second message received are not the same.

    So your solution should (not 100% sure, since I don't know exactly what you are trying to accomplish, a parallel convoy might also be an option) be to set "Ordered Delivery" to True on your Receive Port (Port_1).

    Morten la Cour


    • Marked as answer by _NiLeSh Saturday, October 17, 2015 10:35 AM
    Saturday, October 17, 2015 9:40 AM
  • Thank you la Cour Vertica.

    It worked for me.

    Saturday, October 17, 2015 10:39 AM