locked
Runtime Error when publishing MVC3 ASP.Net application on Azure with TFS RRS feed

  • Question

  • I am new to Azure, TFS.

    I created one simple MVC3ASP.Net application and tried to publish on Azure through TFS.

    It is giving me an error:

    Server Error in '/' Application.

    Runtime Error

    Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine. 

    Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off".
    <!-- Web.Config Configuration File -->
    
    <configuration>
        <system.web>
            <customErrors mode="Off"/>
        </system.web>
    </configuration>

    Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.
    <!-- Web.Config Configuration File -->
    
    <configuration>
        <system.web>
            <customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
        </system.web>
    </configuration>

    I changed the web.config file with <customErrors mode="Off"/> then it throughed me out with an error

     

    Server Error in '/' Application.

    Configuration Error

    Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately. 

    Parser Error Message: Unrecognized attribute 'targetFramework'. Note that attribute names are case-sensitive.

    Source Error: 
    Line 31:       </namespaces>
    Line 32:     </pages>
    Line 33:     <httpRuntime targetFramework="4.0" encoderType="System.Web.Security.AntiXss.AntiXssEncoder, System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" />
    Line 34:     <machineKey compatibilityMode="Framework45" />
    Line 35:     <profile defaultProvider="DefaultProfileProvider">

    Source File: C:\DWASFiles\Sites\CreditKey\VirtualDirectory0\site\wwwroot\web.config    Line: 33 


    Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.276

    While tried to publish through other ways like through PublishingSettings or through FTP, worked fine. But in this case it is throwing the same 

    Please Can anybody help me out.. Iam trying to solve it from morning and it killed all my day.. Thanks in Advance

    Tuesday, June 26, 2012 11:50 PM

Answers

All replies

  • The TF Service was undergoing maintenance most of yesterday, which may have contributed to this issue. Are you still seeing the problem today?

    Trevor Hancock (Microsoft)
    Please remember to "Mark As Answer" the replies that help.

    Wednesday, June 27, 2012 4:31 PM
  • are you still seeing this issue
    Friday, July 6, 2012 5:56 PM
  • This appears to be due to using .NET Framework 4.5, which is not supported in Windows Azure yet.  Please try again with .NET 4.0.
    Wednesday, July 11, 2012 9:35 PM