none
Disable XML Auto-formatting in VS 2013 RRS feed

  • Question

  • I am updating a line-of-business app to VS 2013 and need a way to disable auto-formatting of XML files in the VS editor. Our app uses many XML data files where case and whitespace is significant, and the VS editor inserts newlines and spaces all over the place whenever I try to edit an XML file.

    I have unchecked every option in Tools/Options/Text Editor/XML to no effect. Even pasting unformatted text inserts multiple newlines and space characters.

    Sunday, February 23, 2014 2:23 AM

All replies

  • Hi Dour,

    The default settings in VS IDE which are related to the Auto-formatting are under the Tools->Options->Text Editor.

    As you said that if it is not the result what you want to get, I’m afraid that I have no idea, or you could test it in other VS2013 machines, if it still has this issue, I suggest you submit a user voice.

    You could submit this feature request: http://visualstudio.uservoice.com/forums/121579-visual-studio. The Visual Studio product team is listening to user voice there. You can send your idea there and people can vote. If you submit this suggestion, I hope you could post that link here, I will help you vote it. Thanks for your understanding.

    Best Regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Monday, February 24, 2014 8:56 AM
    Moderator