locked
Grant Select permission on a table RRS feed

  • Question

  • Hi All

    I need to Grant Select permission on a table ,

    when I execute stetment : "GRANT SELECT ON OBJECT::general.mtg_user TO User1;"

    It complated successfully ,but the new permission  is not apply

    please help me

    Saturday, September 5, 2009 11:45 AM

Answers

  • right click on table and go to properties -> permissions tab -> click Add -> browse the user to whom u want to give the permission -> click ok -> now u will find various permissions which u can grant -> in tht tick on select checkbox under grant column.
    • Proposed as answer by SQLUserDBA Monday, September 7, 2009 7:02 AM
    • Marked as answer by Ora-dbaabode Wednesday, September 9, 2009 12:27 AM
    Monday, September 7, 2009 6:12 AM

All replies

  • Most restrictive permission takes precedence. 

    GRANT SELECT
    ON general.mtg_user TO User1 should work, unless use is part of a role which was explicitly denied permission on that table. 

    Saturday, September 5, 2009 1:31 PM
  • Sorry C_Shah

    could give me an example
    Saturday, September 5, 2009 6:28 PM
  • I try grant Select on table permission to my user using SQL Server management studio , and I get no error ,but when view the user property,the permission didn't granted to the user

    I can't grant securables permissions to user
    Saturday, September 5, 2009 7:05 PM
  • in management studio, right click on the table do you see  user  is gratned SELECT permission? 

    Saturday, September 5, 2009 8:50 PM
  • No ,I don't see user  is gratned SELECT permission
    Saturday, September 5, 2009 10:30 PM
  • Are you a  part of sysadmin fixed server role or Database Owner? Just to make sure you have enough permission to grant SELECt to someone else.

    also, as I said earlier that check and make sure that usre is not part of a role that was denied SELECT permission on that table.

    Saturday, September 5, 2009 10:45 PM
  • I logIn as Administrator with Windows Authentication

    the my DataBase is new DataBase
    • Proposed as answer by SQLUserDBA Monday, September 7, 2009 6:08 AM
    Saturday, September 5, 2009 11:39 PM
  • right click on table and go to properties -> permissions tab -> click Add -> browse the user to whom u want to give the permission -> click ok -> now u will find various permissions which u can grant -> in tht tick on select checkbox under grant column.
    • Proposed as answer by SQLUserDBA Monday, September 7, 2009 7:02 AM
    • Marked as answer by Ora-dbaabode Wednesday, September 9, 2009 12:27 AM
    Monday, September 7, 2009 6:12 AM
  • Hi

    use command
    GRANT select ON OBJECT::schema_name.table_name
        TO uer_name;

    note: to do the opeation, you should have the membership in the db_securityadmin fixed database role, membership in the db_owner fixed database role, or membership in the sysadmin fixed server role. For more information, there is an article to share with you:http://msdn.microsoft.com/en-us/library/ms188371(SQL.90).aspx

    Regards


    Monday, September 7, 2009 7:04 AM
  • Thank you Pokiri

    the permission granted to my user successfully

    must the new permission display in user properties/Securables ?

    the new permission not display in user properties/Securables.

    Wednesday, September 9, 2009 12:28 AM
  • If the user is able to read the data from the table then the objective is acheived.

    it is not required [new permission display in user properties/Securables ]

    Wednesday, September 9, 2009 10:33 AM