locked
Deploying lightswitch web application on the server: HTTP Error 500.19 - Internal Server Error RRS feed

  • Question

  • I have a problem with deploying the 3 tier lightswitch web application on the server.

    On the local server IIS7 everything works perfect but when i deploy it to the vps which also runs IIS7 it gives me this error when i try to navigate to the page:

    HTTP Error 500.19 - Internal Server Error The requested page cannot be accessed because the related configuration data for the page is invalid.

    I have published a package on the disc, uploaded it to the server, installed the application under Default Website with success. But when i navigate to the application it shows that error...

    This is what is shown as a problem area:

    1. Config Source
    2. 141: </system.serviceModel>
    3. 142: <uri>
    4. 143: <schemeSettings>

    It is part of the web.config file. When i open it and go there i see this:

    1. <uri>
    2. <schemeSettings>
    3. <add name="http" genericUriParserOptions="DontUnescapePathDotsAndSlashes" />
    4. <add name="https" genericUriParserOptions="DontUnescapePathDotsAndSlashes" />
    5. </schemeSettings>
    6. </uri>

    and add part is underlined which gives me further explanation of the error:

    web.conf error: the element 'schemeSettings' cannot contain child element 'add' because the parent element's content model is empty.

    I tried looking on the internet for the solution but no luck...

    Thank you!

    Friday, December 6, 2013 4:03 PM

Answers

  • Hi Angie,

    I have found what was the problem!

    On the IIS i had DefaultAppPool selected for the application. When i changed it to ASP.NET v4.0 error was gone. This can be done in application basic settings.

    Open IIS Manager, select the application, in the right column of explorer click Basic Settings, click button Select and choose ASP.NET v4.0, click Ok.

    That was it for me. Hope it helps someone...

    • Marked as answer by Angie Xu Monday, December 9, 2013 9:33 AM
    Monday, December 9, 2013 9:32 AM

All replies

  • Hi DarioOs

    HTTP Error 500.19 - Internal Server Error......

    Perhaps you will get error message when you visit a Web site that is hosted on IIS: "HTTP Error 500.19 – Internal Server Error", for this issue, you could refer relevant resolutions below first, and check whether it can fix it.

    "HTTP Error 500.19 – Internal Server Error"

    Regards

    Angie


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Monday, December 9, 2013 7:11 AM
  • Hi Angie,

    I have found what was the problem!

    On the IIS i had DefaultAppPool selected for the application. When i changed it to ASP.NET v4.0 error was gone. This can be done in application basic settings.

    Open IIS Manager, select the application, in the right column of explorer click Basic Settings, click button Select and choose ASP.NET v4.0, click Ok.

    That was it for me. Hope it helps someone...

    • Marked as answer by Angie Xu Monday, December 9, 2013 9:33 AM
    Monday, December 9, 2013 9:32 AM