none
Unable to access mailbox using EWS RRS feed

  • Question

  • Hello :

    I am using EWS for connecting exchange & reading mailbox mails.

    I am also using impersonation.

    I have given full access to admin on mailbox.

    But I got error as Unable to access mailbox, some time it works but sometime gives error.

    Please suggest...

    Thanks,

    Ravindra

    Saturday, September 20, 2014 12:14 PM

Answers

  • Hi Ravindra

    Please check the EWS authentication settings and ensure that they are correctly configured according to the authentication type your application uses.
    I think there should be some issues with the authentication settings between your application and EWS directory.

    First  check what kind of authentication your application uses (basic , form based,anonymous or windows) and set the ews VD accordingly

    Look for any errors in the IIS logs and post them if you see any .



    Remember to mark as helpful if you find my contribution useful or as an answer if it does answer your question.That will encourage me - and others - to take time out to help you Check out my latest blog posts on http://exchangequery.com

    • Marked as answer by __Ravindra__ Tuesday, September 23, 2014 8:30 AM
    Saturday, September 20, 2014 3:22 PM

All replies

  • Hi Ravindra

    Please check the EWS authentication settings and ensure that they are correctly configured according to the authentication type your application uses.
    I think there should be some issues with the authentication settings between your application and EWS directory.

    First  check what kind of authentication your application uses (basic , form based,anonymous or windows) and set the ews VD accordingly

    Look for any errors in the IIS logs and post them if you see any .



    Remember to mark as helpful if you find my contribution useful or as an answer if it does answer your question.That will encourage me - and others - to take time out to help you Check out my latest blog posts on http://exchangequery.com

    • Marked as answer by __Ravindra__ Tuesday, September 23, 2014 8:30 AM
    Saturday, September 20, 2014 3:22 PM
  • If your using Impersonation then you don't need Full Access also, what is the actual error message you are getting. You might want to enable Tracing http://msdn.microsoft.com/en-us/library/office/dd633676(v=exchg.80).aspx and post the response with the error message and also a sample of the code your using. You might also want to read http://blogs.msdn.com/b/pareshj/archive/2011/11/29/exchange-web-services-fail-using-impersonation-to-access-mailboxes.aspx which has all the most common issues listed.

    Cheers
    Glen

    Monday, September 22, 2014 4:55 AM