locked
Control not getting focus in Narrator Touch Navigation

    Question

  • I have a UserControl that I create a CustomAutomationPeer for.

    While tabbing through the app this control gets focus and does the right thing. However, when I tried swyping the control was skipped over.

    I tried setting the IsContent and IsControl properties to true, and also overriding the Get calls in the AutomationPeer to true also and still no luck.

    Tuesday, December 16, 2014 11:17 PM

All replies

  • Hi Frank - I'll ask our accessibility expert to check this out.


    Matt Small - Microsoft Escalation Engineer - Forum Moderator
    If my reply answers your question, please mark this post as answered.

    NOTE: If I ask for code, please provide something that I can drop directly into a project and run (including XAML), or an actual application project. I'm trying to help a lot of people, so I don't have time to figure out weird snippets with undefined objects and unknown namespaces.

    Wednesday, December 17, 2014 2:08 PM
    Moderator