Problem when updating a Deploy RRS feed

  • Question

  • When I deploy my app first time, no problem; but when I try to update it, I use the same schema but in another server, because the Development PC is in a differnte network than the Production Server, when I try to update the App, it throws an exception telling me that the destination server is not the base server where the schema was taken from... so it fails, I thought this problem would be solved for the 2012 version, but in the RC is still not solved.



    Tuesday, June 12, 2012 11:23 AM

All replies

  • you're referring to the sql script error message? if so, check around line 77

    IF (@@servername != '2003LITE2')
        RAISERROR(N'The server name in the build script %s does not match the name of the target server %s. Verify whether your database project settings are correct and whether your build script is up to date.', 16, 127,N'2003LITE2',@@servername) WITH NOWAIT


    Tuesday, June 12, 2012 7:33 PM
  • The very same D:.. I have tryes to change that name, but the script begin to give me lots of errors


    • Edited by sebaxor Tuesday, June 12, 2012 8:03 PM
    Tuesday, June 12, 2012 8:03 PM
  • I think I read the other day some comment of Michael Washington saying that the automatic scheme update of LS deployment is broken :( .. I think we should wait to another version :/

    Someone can say something about this?, is it true?


    Friday, July 27, 2012 12:57 PM
  • No, it's not true that it's "broken". It ust doesn't handle some of the more "complex" updates as well as I'm sure it will in the future.

    Yann - LightSwitch Central - Click here for FREE Themes, Controls, Types and Commands
    If you find a reply helpful, please click "Vote as Helpful", if a reply answers your question, please click "Mark as Answer"
    By doing this you'll help people find answers faster.

    Monday, July 30, 2012 2:12 PM
  • Well stated, Yann...

    Keeping in mind that the scripts we generate have quite a capacity to incur some sort of data loss we're very conservative and will likely always err on the side of preserving data...

    In this particular case (with this specific error) the easiest approach is to simply run through the publish wizard and point to the database you want to update to generate the script.  It can be a challenge if something prohibits you from hitting the SQL Server from your dev box, but there are enough subtle differences between databases that we want to stick with a conservative approach on this one...

    Monday, July 30, 2012 5:36 PM