none
Net Framework RRS feed

  • Question

  • I need a firmware update from HP and I was instructed to have .Net Framework 3.5 SP1 and my programs list says I have .Net Framework 4 Client Profile. Do I still need to install .Net Framework 3.5 sp1?
    Monday, October 10, 2011 4:13 PM

Answers

  • Probably, as the two frameworks are separate and independent. If a program requires 3.5 SP1 specifically, having 4.0 won't work.

    I said probably because in order to give you good guidance, we need to know what Windows version you have.

    If you have Windows 7, .NET Framework 3.5 SP1 is installed as an integral part of the OS. You can find it in COntrol Panel->Programs and Features->Turn Windows features on and off...

    In the Windows Features dialog, you will find the entry "Microsoft .NET Framework 3.5.1"

    You can expand that node and make sure all subfeatures are activated.

    If you have Vista, we need to know if you have a 32 bit or 64 bit edition in order to direct you to the correct download for .NET Framework 3.5 SP1.

    If you have XP, you can use this cumulative installer for .NET Framework 2.0/3.0/3.5 through 3.5 SP1:

    http://download.microsoft.com/download/2/0/e/20e90413-712f-438c-988e-fdaa79a8ac3d/dotnetfx35.exe

     

    • Proposed as answer by Alexander Sun Wednesday, October 12, 2011 6:38 AM
    • Marked as answer by Alexander Sun Tuesday, October 18, 2011 4:23 AM
    Monday, October 10, 2011 7:39 PM