locked
Deploying LS app to web server RRS feed

  • Question

  • I'm still having problem deploying LS 2012 app to IIS7 web server. I'm getting the "not admin" error. Deploying LS app as domain administrator also does not help.

    When will this problem be solved by Microsoft?

    The screen design costumize link also does not appear when I run in debug (F5) mode.

    Wednesday, December 12, 2012 10:31 PM

All replies

  • You don't mention what you've tried, so have you been through:

    How Do I: Deploy a Visual Studio LightSwitch Application? (video)

    Deployment Guide: How to Configure a Web Server to Host LightSwitch Applications (updated)

    Lightswitch Iis Deployment Enhancements In Visual Studio 2012

    Diagnosing Problems In A Deployed 3-Tier Lightswitch Application


    Yann - LightSwitch Central - Click here for FREE Themes, Controls, Types and Commands
     
    Please click "Mark as Answer" if a reply answers your question. Please click "Vote as Helpful" , if you find a reply helpful.
     
    By doing this you'll help others to find answers faster.

    Thursday, December 13, 2012 3:33 AM
    Moderator
  • Please describe what settings you are entering on the first 3 pages of the Publish Wizard.  Also please include the exact error message you are getting.

    David Kidder | Senior SDET | Microsoft | LightSwitch

    Thursday, December 13, 2012 4:38 PM
    Moderator
  • Hereby I send you the screenshots o thef LS app (VS 2012) deploy wizars.

    This is the error I'm getting:

    Error 1 Web deployment task failed. (Connected to 'cur-zgptest-01' using the Web Deployment Agent Service, but could not authorize. Make sure you are an administrator on 'cur-zgptest-01'.  Learn more at: http://go.microsoft.com/fwlink/?LinkId=221672#ERROR_USER_NOT_ADMIN.) C:\Program Files (x86)\MSBuild\Microsoft\VisualStudio\v11.0\Web\Microsoft.Web.Publishing.targets 4377 6 SVB-ZorgPortaal

    LS Deploy Screenshots

    Thursday, December 13, 2012 6:53 PM
  • Hi

    Try to publish your app without checking LightSwitch Deployment Prerequisites Installed option. This might clear your problem. Also check that Web Deployment Agent Service is running or not in your system services. If its stopped Run the service and start the deployment again.

    Follow all the articles what Yann have proposed you. This will help you at the time of deployment LS app.

    Regards 


    Rashmi Ranjan Panigrahi
    www.lightswitchspecial.com

    If you found this post helpful, please “Vote as Helpful”. If it answered your question, please “Mark as Answer”.
    This will help other users to find their answer quickly.

    Thursday, December 13, 2012 7:48 PM
  • Hi,

    I unchecked LightSwitch Deployment Prerequisites, but that does not help.

    I'm working in two different VS enviroments; VS 2010 and VS 2012 (premium). In VS2010 I can deploy the LS app without a problem to the web server. Deploying the converted LS app in VS 2012 to same web server gives me the error I mentioned.

    I will try to publish it via a package.

    Thanks

    Thursday, December 13, 2012 9:58 PM
  • Remote publishing with VS 2012 will attempt to use MS Deploy 2.0, I found this trouble shooting page:

    Common Web Deploy problems and how to troubleshoot them

    Connected to 'remote-server.com' using the Web Deployment Agent Service, but could not authorize. Make sure you are an admin on 'remote-server.com'.

    This happens if you try to connect to the Remote Agent Service but have not provided appropriate administrator credentials.

    The Remote Agent Service accepts either built-in Administrator or Domain Administrator credentials. Because of a bug in Web Deploy, any other administrator credentials (e.g. member of the local Administrators group) will not work and will cause this error.


    David Kidder | Senior SDET | Microsoft | LightSwitch

    • Proposed as answer by Dave KidderModerator Friday, December 14, 2012 1:07 AM
    • Marked as answer by Angie Xu Thursday, December 20, 2012 12:18 AM
    • Unmarked as answer by SVBCUR Sunday, December 23, 2012 3:57 PM
    • Unproposed as answer by SVBCUR Sunday, December 23, 2012 3:57 PM
    Friday, December 14, 2012 1:07 AM
    Moderator
  • Hi SVBCUR

    I will mark Dave Kidder's reply as answer, if the marked answer is not helpful to solve your problem, please unmark and give quick response.

    With regards


    Angie xu
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Thursday, December 20, 2012 12:17 AM
  • I already been to that page and it gave me no solution. I still can not publish the LS app from VS2012. I deployed the LS app by making a deplyment package.

    Thanks

    Sunday, December 23, 2012 4:04 PM
  • What type of user is the user that you specified in the "User name" field in the publish wizard ("svb-cur\administrator)?  Is it a domain user in the Administrators group?

    David Kidder | Senior SDET | Microsoft | LightSwitch

    Saturday, December 29, 2012 1:22 AM
    Moderator
  • Just a question.  But the default uri scheme for Web deploy is https://yourserver.com:8172/MsDeploy.axd.  Could you try that?


    Derek

    Friday, January 4, 2013 8:01 PM