none
HLK Studio Unable to get client machine into Ready state RRS feed

  • Question

  • I'm following the directions to setup HLK Studio to run some tests on a device driver. I installed the HLK Controller on Windows Server 2012 R2. The controller version is 10.1.15063.15063 and studio version 10.0.15063.0.

    I uninstalled and reinstalled the HLK Client software from this machine onto two test machines. The two test machines are running Windows 10 version 1703 - redstone 2. The difference is that one system is 32 bit intel and the other is 64 bit intel. I started HLK Studio on my controller. I created a Project. I go to Configuration and I saw both of my client machines in the Default Pool. So then I created a new Machine pool and gave it a name "HLK Machine Pool" and dragged both client machines into the machine pool I just created. Both of the machines have heartbeats that show up every 10 minutes are so. The value from the "Platform" column says "Windows v10.0 x64 15063 Enterprise" and "Windows v10.0 x86 15063 Enterprise". The status on both machines show "NotReady".

    I then right click the row and choose "Change Machine Status" and from the submenu I choose "Ready". I am expecting that the status will change to "Ready". What actually happens it that the status changes to "Initializing". It stays on Initializing for about 2 minutes or so. After a couple of minutes, the status value for the row changes back to "NotReady". 

    I have tried the following things to try to trouble shoot this:

    Reboot the client machines. Reboot the controller. Turn off IPSec Policy Agent in the Microsoft Management Console. Verified that all three computers (controller and two clients) have port 1771 open.

    When I open HLK Manager (as opposed to HLK Studio) I also see my machine pool. The status there says "Debug". I'm not sure what it should say here. I read on a troubleshooting page a question about what to do if the status won't change from Debug even after a Reset. Since Reset is a status I can choose, I tried choosing it. The status changed to Reset. After a while it changed back to Debug.

    Any ideas what I should try?

    Thursday, August 31, 2017 9:05 PM

All replies

  • In my experience,
    (1) Move the machine in Machine Pool to default pool.
    (2) Delete the machine moved to the default pool.
    (3) Restart the HLK Client OS of the deleted machine.
    (4) Since the machine appears in the default pool, move the machine to Machine Pool.
    (5) Set the machine moved to Machine Pool to Ready.

    Since the machine information of the previously recognized HLK Client remained, since it did not become Ready,
    Removing the HLK Client machine on the HLK Controller has been successful, as it did successfully.
    Friday, September 1, 2017 12:05 AM
  • I'm having this similar issue and have tried these steps multiple times, with no resolve.  Still having the same issue.  ONLY with 2012/2012r2


    Any help would be great! 

    Wednesday, November 22, 2017 12:34 PM
  • Hi Ren,

    1. Check your network connection and firewall.

    2. Is your system version same with HLK studio version(WIN10_RS3_1709 need HLK_1709)

    3. Remove your client package about  WHQL test tool and restart to install from your server again.

    Friday, November 24, 2017 2:41 AM
  • Hey Chein-Ta!

    I have allowed inbound and outbound connections on my firewall

    i have uninstalled/reinstalled my client multiple times.

    This is HCK not HLK.

    What i have Doner/found:
         This issue only appears with server versions 2012, 2012r2, 2k8r2 sp1.

         I thought it was correlated to some IPv6 issue, but i have hardwired and can ping through a transition from Ready -> Running -> NotReady.

         I checked the logs and then saw something correlating to potentially not enough RAM, so i added more memory and am running over 4g RAM.

         I have rebooted both my server and clients.

    Note: Again, this issue doesn't appear with my win 7, win 8.1 boxes.  Only 

    I really thought it was some weird IPv6 communications, but now i'm at a loss and the logs really don't provide any real direction.

    I'm rebuilding my server since it was on an 180day activated MS test machine.

    Any help would be GREAT! I have been making a lot of dumb decisions out of desperation and now have to rerun my already passed tests...I am sad and really faced against a creeping timeline.

    Thanks!!

    • Edited by Ren MG Friday, November 24, 2017 1:13 PM
    Friday, November 24, 2017 4:28 AM
  • Hi Ren,

    Maybe you should make sure it is available about the environment of WHQL server you used.

    I remembered I had ever used 180 activated windows server 2012 r2 version. But finally, I translate to a normal version with an activated key.

    Did you run WHQL test in trial version first time?

    Friday, December 1, 2017 1:52 AM
  • Please see the following link on how troubelshoot HLK Client issues:

    https://docs.microsoft.com/en-us/windows-hardware/test/hlk/user/troubleshooting-windows-hlk-client#debugstate 

    Cannot get a client computer out of Debug state

    Problem. The Client does not change from the Debug state to the Ready state, even after changing the state to Reset in Windows HLK Manager.

    This problem can be caused by a lack of communication between the Windows HLK Controller computer and the Windows HLK Client computer, or by a trusted key mismatch between the two systems.

    Try these solutions in the following order:

    1. Try the solutions in Client computers cannot communicate with the Windows HLK Controller.

    2. Reinstall the Client using the steps in Remove and reinstall the Windows HLK Client.


    Thanks!

    Friday, December 1, 2017 9:00 PM