locked
npm failed with error code: 1 RRS feed

  • Question

  • Hi,

    I am using Microsoft azure for our front end web application,VSTS is used for push the code and continuous integration when i publishing the code getting npm build issue,i.e npm failed with error code: 1.

    Configuration of Project:
    Ionic4 Angular

    my package.json file.
       "dependencies": {
            "@angular/animations": "^6.1.10",
            "@angular/cdk": "^6.4.7",
            "@angular/common": "~6.1.1",
            "@angular/core": "~6.1.1",
            "@angular/forms": "~6.1.1",
            "@angular/http": "~6.1.1",
            "@angular/material": "^6.4.7",
            "@angular/material-moment-adapter": "6.4.6",
            "@angular/platform-browser": "~6.1.1",
            "@angular/platform-browser-dynamic": "~6.1.1",
            "@angular/router": "~6.1.1",
            "@ionic-native/core": "5.0.0-beta.21",
            "@ionic-native/splash-screen": "5.0.0-beta.21",
            "@ionic-native/status-bar": "5.0.0-beta.21",
            "@ionic/angular": "4.0.0-beta.13",
            "@ionic/storage": "^2.2.0",
            "@swimlane/ngx-charts": "^10.0.0",
            "angular-2-local-storage": "^2.0.0",
            "bootstrap": "^4.3.1",
            "build": "0.1.4",
            "chart.js": "^2.7.3",
            "cordova-android": "7.1.3",
            "cordova-browser": "5.0.4",
            "cordova-plugin-device": "^2.0.2",
            "cordova-plugin-ionic-keyboard": "^2.1.3",
            "cordova-plugin-ionic-webview": "^2.2.5",
            "cordova-plugin-splashscreen": "^5.0.2",
            "cordova-plugin-statusbar": "^2.4.2",
            "cordova-plugin-whitelist": "^1.3.3",
            "core-js": "^2.5.3",
            "deepmerge": "^3.3.0",
            "local-storage": "^1.4.2",
            "moment": "^2.24.0",
            "ng-material-multilevel-menu": "^4.9.2",
            "ng-multiselect-dropdown": "^0.2.3",
            "ng2-charts": "^1.6.0",
            "ng2-filter-pipe": "^0.1.10",
            "node-schedule": "^1.3.1",
            "parse": "^2.1.0",
            "primeicons": "^2.0.0",
            "primeng": "^8.0.4",
            "rxjs": "6.2.2",
            "toast-controller": "^0.11.6",
            "xlsx": "^0.14.1",
            "zone.js": "^0.8.26"
        },
        "devDependencies": {
            "@angular-devkit/architect": "~0.8.5",
            "@angular-devkit/build-angular": "^0.12.4",
            "@angular-devkit/core": "~0.8.5",
            "@angular-devkit/schematics": "~0.8.5",
            "@angular/cli": "~6.2.5",
            "@angular/compiler": "~6.1.1",
            "@angular/compiler-cli": "^8.1.2",
            "@angular/language-service": "~6.1.1",
            "@ionic/angular-toolkit": "^1.0.0",
            "@ionic/lab": "2.0.11",
            "@types/jasmine": "~2.8.6",
            "@types/jasminewd2": "~2.0.3",
            "@types/node": "~10.12.0",
            "codelyzer": "~4.5.0",
            "jasmine-core": "~2.99.1",
            "jasmine-spec-reporter": "~4.2.1",
            "karma": "^4.2.0",
            "karma-chrome-launcher": "~2.2.0",
            "karma-coverage-istanbul-reporter": "~2.0.0",
            "karma-jasmine": "~1.1.1",
            "karma-jasmine-html-reporter": "^0.2.2",
            "protractor": "~5.4.0",
            "ts-node": "~7.0.0",
            "tslint": "~5.11.0",
            "typescript": "3.4.5"
        },

    Thanks
    GopiNadhYadavallli
    Friday, November 29, 2019 5:35 AM

All replies