locked
Visual Studio 2013 RRS feed

  • Question

  • I finally got Visual Studio 2013 version 4.6 installed and working, but when I imported the settings from my laptop, (same compiler version), it took away my ability to change the text editor font size and color.  It's way too big...source code text font won't change

    How can I get back my ability to change the font size and color for the source code editing?

    Wednesday, September 14, 2016 6:58 PM

All replies

  • Hi TallGuy63,

    Welcome to MSDN forum.

    Firstly, please select Tools--Import and Export settings , and then select Reset all settings. Click next button to save your current settings, finally it will reset the setting to the default ones.

    After that, please change the text editor font size and color and see if it works or not. If it works, which means this issue is related to your imported setting.

    If not, go to Control Panel—Programs and Features, right-click the VS 2013 and change-repair.

    Or you can also upload your setting file to https://onedrive.live.com/ and share the link here, we will import it on my local computer and try to reproduce your issue.

    Best regards,

    Sara


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place. Click HERE to participate the survey.

    Thursday, September 15, 2016 7:21 AM
  • I did the reset and then went through all the preferences.

    The font size and color did not change.

    I don't see anywhere else to change my source's font; I'm using "All Text Tool Windows" because there is no "Source Code Text" setting anywhere. Anywhere I change the font size or color, it does not change my source code's font

    Thursday, September 15, 2016 3:54 PM
  • Hi TallGuy63,

    Thank you for your update.

    >>I'm using "All Text Tool Windows" because there is no "Source Code Text" setting anywhere.

    I have checked the 'All Text Tool Windows' as below, it looks like there is no 'Source Code Text'.

    Try to reproduce your issue, please provide the detail information as below:

    1. The VS 2013 version

    2. Upload and share the screenshot when you change the font size or color to https://onedrive.live.com/

    3. How did you check the result after you changed the font size or color? Like the project type

    Best regards,

    Sara


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place. Click HERE to participate the survey.


    Friday, September 16, 2016 7:38 AM
  • Hi, thanks for the response.... The "Plain Text" setting doesn't change anything.

    Look at my screen capture and you will see that the background color I imported is blueish... yet the "Plain Text" shows gray.  This color setting in Visual Studio is clearly not working.

    http://www.jimseekamp.com/VS2013_screenshot.jpg

    Friday, September 16, 2016 10:27 PM
  • Hi TallGuy63,

    I have checked your screenshot, and cannot found the blueish that you mentioned, please see the following:

    Meanwhile, I found there is no option 'blueish' in the dropdown of 'Item background', do you means color 'Cyan' or custom color?

    Since you chose the 'All Text Tool Windows', how about choose the 'Text Editor' in the 'Show settings for', I have tried it and found the background become cyan:

    Best regards,

    Sara


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place. Click HERE to participate the survey.

    Monday, September 19, 2016 8:27 AM
  • I don't have a 'Text Editor'  category.

    The color I'm trying to use is customn; a little lighter than Cyan...

    The background color does not change using [All Test Tool Windows] and there IS NO "Text Editor" category !

    Monday, September 19, 2016 1:35 PM
  • Hi TallGuy63,

    >>The color I'm trying to use is customn; a little lighter than Cyan...

    If you selected a custom color, the value of 'Item background' should display as 'Custom' and not the 'Default' in your screenshot and the background of the 'Sample' also not change, please have a try with click the 'Custom' button and add a new custom color and see if the value will update or not.

    >>there IS NO "Text Editor" category !

    It looks like the ‘Text Editor’ is missing in your VS 2013, please have a look at this similar issue:

    http://stackoverflow.com/questions/27381891/missing-text-editor-font-size-setting-in-vs2013

    Boris Salimov:

    I was found workaround. I was manually add some rows to .vssettings file (located in user/Documents and Settings/Visual Studio 2013 by default). It rows need to add to Fonts and Colors section:

    <Category GUID="{58E96763-1D3B-4E05-B6BA-FF7115FD0B7B}" FontName="Consolas" FontSize="12" CharSet="1" FontIsDefault="No"/>
    <Category GUID="{75A05685-00A8-4DED-BAE5-E7A50BFA929A}" FontName="Consolas" FontSize="12" CharSet="1" FontIsDefault="No"/>
    <Category GUID="{E0187991-B458-4F7E-8CA9-42C9A573B56C}" FontName="Consolas" FontSize="12" CharSet="1" FontIsDefault="No"/>
    <Category GUID="{FF349800-EA43-46C1-8C98-878E78F46501}" FontName="Consolas" FontSize="12" CharSet="1" FontIsDefault="No"/>
    

    I was copy and pasted this options from working VS2012 settings.

    If you have installed the SQL Server 2014 Business Intelligence, you can also take a look at this: http://stackoverflow.com/questions/26629964/missing-text-editor-setting-in-fonts-and-colors

    Mike: The problem turned out to be with SQL Server 2014 Business Intelligence. I re-installed that and everything worked.

    Best regards,

    Sara


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place. Click HERE to participate the survey.

    Tuesday, September 20, 2016 7:34 AM