locked
Encoding issue with MySQL data RRS feed

  • Question

  • I'm trying to take data from MySQL database using ADF MySQL connector. Data flow from source to sink works but the values are coming through as gobbledygook. Guessing this is an encoding issue that needs to be explicitly set somewhere.

    Examples of data errors taken from ADF table preview

    "Flagged" displays as "RmxhZ2dlZA=="
    "Epic/Theme" displays as "RXBpYy9UaGVtZQ=="

    "Story Points" displays as -> "U3RvcnkgUG9pbnRz"

    I tried specifying the below connection property to the ADF MySQL linked service configuration but didn't resolve it

    Property name = treatblobsasutf8

    Value = true


    What configuration change needs to be made to treat this data correctly?

    Note: we're trying to extract data from JIRA server. Initially tried the Jira connector which doesn't provide access to the <g class="gr_ gr_33 gr-alert gr_spell gr_inline_cards gr_run_anim ContextualSpelling ins-del multiReplace" data-gr-id="33" id="33">customfields</g> which are absolutely essential. Hence now trying <g class="gr_ gr_45 gr-alert gr_gramm gr_inline_cards gr_run_anim Grammar multiReplace" data-gr-id="45" id="45">direct</g> to database source.


    • Edited by Josh Yeats Tuesday, November 13, 2018 3:52 AM html formatting issue
    Tuesday, November 13, 2018 3:51 AM

All replies

  • Decoding RmxhZ2dlZA== from base64 returns the true value. Now to find how to set this in ADF?
    Tuesday, November 13, 2018 10:49 PM
  • Did you check the actually value stored in MySQL? If it's stored as base64 encoding in your DB, it will be read as base64 string out in ADF.
    Thursday, November 15, 2018 4:49 AM
  • You can try the sql like below, supposing the Message column is the column contains base64 string.

    SELECT from_base64(Message) FROM mytable;


    Thursday, November 15, 2018 4:50 AM