locked
There is no Web named "_/layouts/listfeed.aspx." RRS feed

  • Question

  • I have this showing up in the logs driving me crazy.  It seems a site was deleted.  The site is deleted but the rssfeed is still being referenced. 

    Name=Request (GET:http://myserver:80/amle/_layouts/listfeed.aspx?List=c493b1f5%2D6b1e%2D4b31%2D8df4%2Df0c423d41e08)
    Possible mismatch between the reported error with code = 0x81070504 and message: "There is no Web named "/amle/_layouts/listfeed.aspx"." and the returned error with code 0x80070002.

    There is no Web named "/amle/_layouts/listfeed.aspx".

    System.NullReferenceException: Object reference not set to an instance of an object.    at Microsoft.SharePoint.WebControls.LayoutsPageBase.set_PageTarget(ISecurableObject value)     at Microsoft.SharePoint.ApplicationPages.ListFeed.get_List()     at Microsoft.SharePoint.ApplicationPages.ListFeed.OnPreInit(EventArgs e)     at System.Web.UI.Page.PerformPreInit()     at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

    I tried to use powershell to "delete" the site but I felt kind of stupid since it is already telling me the site doesn't exist. Powershell confirmed my thoughts by stating it couldn't find the spweb object.  Duh :/  I do want to point out that the listfeed.aspx does exist in the layouts folder but I'm not sure how I can edit this or what I need to do with the listfeed.aspx.

    Any suggestions are greatly appreciated.

    Thanks,

    Jen


    Jennifer Knight (MCITP, MCPD)

    Monday, January 21, 2013 7:42 PM

Answers

  • Hi,

    It seems the RSS feeds are being referred from somewhere.

    Hence I would suggest you to enable Verbose mode of logging and observe the source location from which these RSS feeds are refrenced.

    I hope this will help you out


    Thanks, Rahul Rashu

    Tuesday, January 22, 2013 3:50 AM