locked
Unable to Start Azure Data Factory Trigger - Missing or invalid pipeline references for trigger Trigger_c2 RRS feed

  • Question

  • Community,

    The following Powershell Command will successfully stop my Tumbling Triggers:

    $triggersADF = Get-AzDataFactoryV2Trigger -DataFactoryName $DataFactoryName -ResourceGroupName $ResourceGroupName
    
    $triggersADF | ForEach-Object { Stop-AzDataFactoryV2Trigger -ResourceGroupName $ResourceGroupName -DataFactoryName $DataFactoryName -Name $_.name -Force }

    However, when I run the command to restart the triggers I get the following error

    $triggersADF = Get-AzDataFactoryV2Trigger -DataFactoryName $DataFactoryName -ResourceGroupName $ResourceGroupName
    
    $triggersADF | ForEach-Object { Start-AzDataFactoryV2Trigger -ResourceGroupName $ResourceGroupName -DataFactoryName $DataFactoryName -Name $_.name -Force }

    I get the following error:

    $triggersADF | ForEach-Object { Start-AzDataFactoryV2Trigger -ResourceGroupName $ResourceGroupName -DataFactoryName $DataFactoryName -Name $_.name -Force }
    True
    Start-AzDataFactoryV2Trigger : HTTP Status Code: BadRequest
    Error Code: BadRequest
    Error Message: Missing or invalid pipeline references for trigger Trigger_az4
    Request Id: 08b0e51a-9a3d-4662-ba8c-8ea62279c558
    Timestamp (Utc):10/21/2019 21:05:10
    At line:3 char:33
    + ... ch-Object { Start-AzDataFactoryV2Trigger -ResourceGroupName $Resource ...
    +                 ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : CloseError: (:) [Start-AzDataFactoryV2Trigger], CloudException
        + FullyQualifiedErrorId : Microsoft.Azure.Commands.DataFactoryV2.StartAzureDataFactoryTriggerCommand
    
    Start-AzDataFactoryV2Trigger : HTTP Status Code: BadRequest
    Error Code: BadRequest
    Error Message: Missing or invalid pipeline references for trigger Trigger_c2l
    Request Id: 86a0199d-5399-4079-abd4-7fe6973df222
    Timestamp (Utc):10/21/2019 21:05:11
    At line:3 char:33
    + ... ch-Object { Start-AzDataFactoryV2Trigger -ResourceGroupName $Resource ...
    +                 ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : CloseError: (:) [Start-AzDataFactoryV2Trigger], CloudException
        + FullyQualifiedErrorId : Microsoft.Azure.Commands.DataFactoryV2.StartAzureDataFactoryTriggerCommand

    Can someone please let me know why I'm getting the error. And what is needed to fix it?

    Cheers

    Carlton



    carlton

    Tuesday, October 22, 2019 2:58 PM

All replies

  • The triggers mentioned in error - Trigger_az4, Trigger_c2I

    Can you check from Azure portal - ADF UI if these triggers are being used in any pipeline? If not delete it else use it in some pipeline and try to execute the script.


    Regards,
    Vaibhav

    Tuesday, October 22, 2019 6:16 PM
  • We did looked into this and at this time we are confident the trigger Trigger_az4 , is not mapped to any pipeline . If we navigate to ADF Ui -> Author -> Triggers -> << your trigger name >> -> please look at the column "number of pipeline" , it should be showing 0 . The triggers needs to be mapped to a pipeline , once you do that and run the query it will work fine 

    Thanks Himanshu

    Tuesday, October 22, 2019 9:28 PM
  • Thank Vaibhav and Himanshu

    The trigger wasn't mapped to a pipeline as you suggested.

    After mapping the Trigger to a pipeline everything worked fine.

    I will mark this question closed.

    Many many thanks for your help


    carlton7372

    Tuesday, October 22, 2019 10:03 PM
  • Question to MSFT Moderators: 

    If user confirms that the issue is resolved but forgot to mark the helpful replies as answers, can Moderators mark it or is it not allowed?


    Regards,
    Vaibhav

    Monday, November 4, 2019 7:24 AM
  • We can mark "Propose as answer" , but not "Mark as a answer" .


    Thanks Himanshu

    Monday, November 4, 2019 8:21 PM