locked
Deployment failed to complete in 30 minutes RRS feed

  • Question

  • I'm deploying the TP3 Azure Stack, and stuck with 40.41, the error is:

    Task: Invocation of interface 'Deployment' of role 'Cloud\Fabric\VirtualMachines' failed:

    Type 'Deployment' of Role 'VirtualMachines' raised an exception:

    Deployment failed to complete in 30 minutes - AzS-SLB01,AzS-Gwy01 .

    The first time that I got this error, I restarted both servers, and used the following command to resume the deployment:

    Import-Module C:\CloudDeployment\CloudDeployment.psd1 -Force
    Import-Module C:\CloudDeployment\ECEngine\EnterpriseCloudEngine.psd1 -Force
    Invoke-EceAction -RolePath Cloud -ActionType Deployment -Start 40.40

    But again the same error.

    I removed the complete environment, and started all over, but still the same error.

    Anyone with a possible solution?

    Wednesday, July 12, 2017 6:57 PM

Answers

All replies

  • Hi,

    Can you please retry using the latest release of the Azure Stack Development Kit. TP3 is no longer supported. You can find information here:https://docs.microsoft.com/en-us/azure/azure-stack/azure-stack-asdk-release-notes

    Thanks,

    Peter

    • Proposed as answer by Peter Pacent Wednesday, July 12, 2017 11:17 PM
    Wednesday, July 12, 2017 11:17 PM
  • Hi Peter,

    it turns out that I'm already using the Azure Stack Development Kit, not the TP3, sorry for the incorrect information.

    Thursday, July 13, 2017 7:50 AM
  • One step further, I used a non-onmicrosoft.com account to connect to Azure. I changed that, and now the installation is continuing...
    Monday, July 17, 2017 7:12 AM
  • i have same issue. still wait for solution.
    Friday, August 18, 2017 3:25 PM