none
Unattended answer file ignored at windows setup? RRS feed

  • Question

  • Hi

    I'm relatively new to preparing images in general and I'm still figuring my way around the ADK. I've made an answer file according to the documentation, but theres clearly something I've missed as Windows Setup is still requiring input (language, locale, etc). 

    I hope this is the current forum, but feel free to move it if it's incorrect.

    It's called "Autounattend.xml" and it's in the root directory of the installation media.

    This is my answer file and it's paired to a Windows 10 Enterprise LTSB: 

    <?xml version="1.0" encoding="utf-8"?>
    <unattend xmlns="urn:schemas-microsoft-com:unattend">
        <servicing>
            <package action="configure">
                <assemblyIdentity name="Microsoft-Windows-Foundation-Package" version="10.0.17134.1" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="" />
                <selection name="Internet-Explorer-Optional-amd64" state="false" />
                <selection name="Printing-Foundation-Features" state="false" />
                <selection name="Printing-PrintToPDFServices-Features" state="false" />
                <selection name="Printing-XPSServices-Features" state="false" />
                <selection name="SearchEngine-Client-Package" state="false" />
                <selection name="SmbDirect" state="false" />
                <selection name="Windows-Defender-Default-Definitions" state="false" />
                <selection name="WorkFolders-Client" state="false" />
                <selection name="Microsoft-Windows-Printing-PrintToPDFServices-Package" state="false" />
                <selection name="Microsoft-Windows-Printing-XPSServices-Package" state="false" />
                <selection name="MediaPlayback" state="false" />
                <selection name="Microsoft-Hyper-V-All" state="true" />
                <selection name="NetFx3" state="true" />
            </package>
        </servicing>
        <settings pass="specialize">
            <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <OEMInformation>
                    <Manufacturer>removed</Manufacturer>
                    <SupportURL>[ REPLACE WITH SUPPORT WEBSITE ]</SupportURL>
                </OEMInformation>
            </component>
        </settings>
        <settings pass="windowsPE">
            <component name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <InputLocale>en-GB</InputLocale>
                <SystemLocale>en-GB</SystemLocale>
                <UILanguage>en-US</UILanguage>
                <UserLocale>en-GB</UserLocale>
            </component>
            <component name="Microsoft-Windows-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <DiskConfiguration>
                    <Disk wcm:action="add">
                        <CreatePartitions>
                            <!-- Windows RE Tools partition -->
                            <CreatePartition wcm:action="add">
                                <Order>1</Order>
                                <Size>300</Size>
                                <Type>Primary</Type>
                            </CreatePartition>
                            <!-- System partition (ESP) -->
                            <CreatePartition wcm:action="add">
                                <Order>2</Order>
                                <Size>100</Size>
                                <Type>EFI</Type>
                            </CreatePartition>
                            <!-- Microsoft reserved partition (MSR) -->
                            <CreatePartition wcm:action="add">
                                <Order>3</Order>
                                <Size>128</Size>
                                <Type>MSR</Type>
                            </CreatePartition>
                            <!-- Windows partition -->
                            <CreatePartition wcm:action="add">
                                <Order>4</Order>
                                <Extend>true</Extend>
                                <Type>Primary</Type>
                            </CreatePartition>
                        </CreatePartitions>
                        <ModifyPartitions>
                            <!-- Windows RE Tools partition -->
                            <ModifyPartition wcm:action="add">
                                <Order>1</Order>
                                <PartitionID>1</PartitionID>
                                <Label>WINRE</Label>
                                <Format>NTFS</Format>
                                <TypeID>de94bba4-06d1-4d40-a16a-bfd50179d6ac</TypeID>
                            </ModifyPartition>
                            <!-- System partition (ESP) -->
                            <ModifyPartition wcm:action="add">
                                <Order>2</Order>
                                <PartitionID>2</PartitionID>
                                <Label>System</Label>
                                <Format>FAT32</Format>
                            </ModifyPartition>
                            <!-- Microsoft reserved partition (MSR) -->
                            <ModifyPartition wcm:action="add">
                                <Order>3</Order>
                                <PartitionID>3</PartitionID>
                            </ModifyPartition>
                            <!-- Windows partition -->
                            <ModifyPartition wcm:action="add">
                                <Order>4</Order>
                                <PartitionID>4</PartitionID>
                                <Label>Windows</Label>
                                <Format>NTFS</Format>
                            </ModifyPartition>
                        </ModifyPartitions>
                        <DiskID>0</DiskID>
                        <WillWipeDisk>true</WillWipeDisk>
                    </Disk>
                    <WillShowUI>OnError</WillShowUI>
                </DiskConfiguration>
                <ImageInstall>
                    <OSImage>
                        <InstallTo>
                            <DiskID>0</DiskID>
                            <PartitionID>4</PartitionID>
                        </InstallTo>
                    </OSImage>
                </ImageInstall>
                <UserData>
                    <AcceptEula>true</AcceptEula>
                    <ProductKey>
                        <WillShowUI>OnError</WillShowUI>
                        <Key>removed</Key>
                    </ProductKey>
                </UserData>
            </component>
        </settings>
        <settings pass="offlineServicing">
            <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <ComputerName>Reference</ComputerName>
            </component>
        </settings>
        <settings pass="oobeSystem">
            <component name="Microsoft-Windows-International-Core" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <InputLocale>en-GB</InputLocale>
                <UILanguage>en-US</UILanguage>
                <SystemLocale>en-GB</SystemLocale>
                <UILanguageFallback></UILanguageFallback>
                <UserLocale>en-GB</UserLocale>
            </component>
            <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <AutoLogon>
                    <Enabled>true</Enabled>
                    <Username>removed</Username>
                </AutoLogon>
                <UserAccounts>
                    <AdministratorPassword>
                        <Value>YwBhAGQAYQBjAEEAZABtAGkAbgBpAHMAdAByAGEAdABvAHIAUABhAHMAcwB3AG8AcgBkAA==</Value>
                        <PlainText>false</PlainText>
                    </AdministratorPassword>
                    <LocalAccounts>
                        <LocalAccount wcm:action="add">
                            <Name>removed</Name>
                        </LocalAccount>
                    </LocalAccounts>
                </UserAccounts>
                <TimeZone>GMT Standard Time</TimeZone>
                <OOBE>
                    <HideEULAPage>true</HideEULAPage>
                    <HideLocalAccountScreen>true</HideLocalAccountScreen>
                    <HideOEMRegistrationScreen>true</HideOEMRegistrationScreen>
                    <HideOnlineAccountScreens>true</HideOnlineAccountScreens>
                    <HideWirelessSetupInOOBE>true</HideWirelessSetupInOOBE>
                    <ProtectYourPC>3</ProtectYourPC>
                </OOBE>
            </component>
        </settings>
        <cpi:offlineImage cpi:source="wim:e:/sources/install.wim#Windows 10 Enterprise Evaluation" xmlns:cpi="urn:schemas-microsoft-com:cpi" />
    </unattend>


    • Edited by AMemhave Thursday, August 9, 2018 9:38 AM
    Thursday, August 9, 2018 9:00 AM

Answers

  • Yeah, there was a host of issues with my XML.

    1) You should remember to set the correct localisation or your image can't be unattended. You can see what localisation you need because the Setup will have it as default (if there are even any other options).

    2) (Not sure about this one) Try not to use an evaluation image as it doesnt seem to like AutoUnattends for whatever reason and shits itself.

    3) Have a proper license key(?), I don't know if you can do "mostly" autounattend without a key. Removing the key directly from the XML seemed to cause some issues too.

    Thanks for the help Sean.


    • Marked as answer by AMemhave Monday, August 13, 2018 11:46 AM
    • Edited by AMemhave Monday, August 13, 2018 11:47 AM
    Monday, August 13, 2018 11:46 AM

All replies

  • Are you creating this answer file using System Image Manager? Or are you creating this by another editor?

    Looks like you are missing the SetupUILanguage under Microsoft-Windows-International-Core-WinPE


    Sean Liming - Book Author: Starter Guide Windows 10 IoT Enterprise - www.annabooks.com / www.seanliming.com

    Thursday, August 9, 2018 10:58 PM
    Moderator
  • Yeah, I'm using System Image Manager. I recently picked up that book too and I followed it. This is the answer file I made and it is still being ignored. Maybe theres a specific bios setting I need to set?

    Edit: on the advice of someone else, I enabled some deprecated keys in the OOBE subsystem, no change.

    AutoUnattend.xml:

    <?xml version="1.0" encoding="utf-8"?>
    <unattend xmlns="urn:schemas-microsoft-com:unattend">
        <settings pass="windowsPE">
            <component name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <InputLocale>en-US</InputLocale>
                <SystemLocale>en-US</SystemLocale>
                <UILanguage>en-US</UILanguage>
                <UILanguageFallback>en-US</UILanguageFallback>
                <UserLocale>en-US</UserLocale>
                <SetupUILanguage>
                    <UILanguage>en-US</UILanguage>
                </SetupUILanguage>
            </component>
            <component name="Microsoft-Windows-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <ImageInstall>
                    <OSImage>
                        <InstallFrom>
                            <MetaData wcm:action="add">
                                <Key>/IMAGE/NAME</Key>
                                <Value>Windows 10 Enterprise Evaluation</Value>
                            </MetaData>
                        </InstallFrom>
                    </OSImage>
                </ImageInstall>
                <UserData>
                    <ProductKey>
                        <Key>removed</Key>
                        <WillShowUI>OnError</WillShowUI>
                    </ProductKey>
                    <AcceptEula>true</AcceptEula>
                </UserData>
            </component>
        </settings>
        <settings pass="specialize">
            <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <AutoLogon>
                    <Password>
                        <Value>cABhAHMAcwB3AG8AcgBkAFAAYQBzAHMAdwBvAHIAZAA=</Value>
                        <PlainText>false</PlainText>
                    </Password>
                    <Username>EcoMixer</Username>
                    <LogonCount>4294967294</LogonCount>
                    <Enabled>true</Enabled>
                </AutoLogon>
                <ComputerName>EcoMixer</ComputerName>
                <TimeZone>GMT Standard Time</TimeZone>
            </component>
        </settings>
        <settings pass="oobeSystem">
            <component name="Microsoft-Windows-International-Core" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <SystemLocale>en-US</SystemLocale>
                <UILanguage>en-US</UILanguage>
                <UserLocale>en-US</UserLocale>
            </component>
            <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <OOBE>
                    <HideEULAPage>true</HideEULAPage>
                    <ProtectYourPC>3</ProtectYourPC>
                    <HideLocalAccountScreen>true</HideLocalAccountScreen>
                    <HideOEMRegistrationScreen>true</HideOEMRegistrationScreen>
                    <HideOnlineAccountScreens>true</HideOnlineAccountScreens>
                    <HideWirelessSetupInOOBE>true</HideWirelessSetupInOOBE>
                    <SkipMachineOOBE>true</SkipMachineOOBE>
                    <SkipUserOOBE>true</SkipUserOOBE>
                </OOBE>
                <UserAccounts>
                    <LocalAccounts>
                        <LocalAccount wcm:action="add">
                            <Password>
                                <Value>cABhAHMAcwB3AG8AcgBkAFAAYQBzAHMAdwBvAHIAZAA=</Value>
                                <PlainText>false</PlainText>
                            </Password>
                            <DisplayName>EcoMixer</DisplayName>
                            <Name>EcoMixer</Name>
                            <Group>Administrators</Group>
                        </LocalAccount>
                    </LocalAccounts>
                </UserAccounts>
            </component>
        </settings>
        <cpi:offlineImage cpi:source="wim:e:/sources/install.wim#Windows 10 Enterprise Evaluation" xmlns:cpi="urn:schemas-microsoft-com:cpi" />
    </unattend>

    heh, I just noticed you're the author.




    • Edited by AMemhave Monday, August 13, 2018 8:35 AM
    Friday, August 10, 2018 11:20 AM
  • So to "fix" this, I removed the product key I, this caused the installation to go forward but now I get:

    "Windows cannot find the Microsoft License Terms".


    Edit: safe to ignore this for now as I don't think this is the issue.
    • Edited by AMemhave Monday, August 13, 2018 8:44 AM
    Friday, August 10, 2018 2:12 PM
  • What key did you enter? Was this an official run-time key from your distributor?

    BTW - you should not be giving out the run time key as it is assigned to your company. Please edit your posts above.


    Sean Liming - Book Author: Starter Guide Windows 10 IoT Enterprise - www.annabooks.com / www.seanliming.com


    Friday, August 10, 2018 3:57 PM
    Moderator
  • Alright, it just removed my huge reply that I typed. Never mind.

    So I removed the key from the XML - it was just a generic one that I was using to test. The actual key that I have is from an MS-MSDN subscription. It's W10 Enterprise 2016 LTSB key. Should I remove the hashes in the XML too?

    I'm going to run through chapters one to two again as I have a feeling the key fiddling messed up the install but I will update later today hopefully. 

    P.S. Sorry for the late reply, I can't access my files remotely just yet.

    Monday, August 13, 2018 8:44 AM
  • Yeah, that seems to have cleared up the licensing issues. So I think I made some progress - now it's not asking for the product key (miracle), but only for the localisation/language stuff (unintended) and disk setup (intended).

    Thoughts? I don't think this is intended as you mention at 2.7 step 8 that it should boot to disk setup.

    Thoughts on why it's asking for localisation?

    So I changed the localisation/language values to be en-GB with the exception of:

    <UILanguage>en-US</UILanguage>

    Because I was told that:

                "When dealing with the English language, be aware that the Master is US first, everything else                is deemed a child of that parent settings. Ergo en-US is the main UI Language and the                          variants can then be the regional settings." [sic]

    I will try it out all en-GB values, to see if it changes anything.

    • Edited by AMemhave Monday, August 13, 2018 11:40 AM
    Monday, August 13, 2018 9:48 AM
  • Yeah, there was a host of issues with my XML.

    1) You should remember to set the correct localisation or your image can't be unattended. You can see what localisation you need because the Setup will have it as default (if there are even any other options).

    2) (Not sure about this one) Try not to use an evaluation image as it doesnt seem to like AutoUnattends for whatever reason and shits itself.

    3) Have a proper license key(?), I don't know if you can do "mostly" autounattend without a key. Removing the key directly from the XML seemed to cause some issues too.

    Thanks for the help Sean.


    • Marked as answer by AMemhave Monday, August 13, 2018 11:46 AM
    • Edited by AMemhave Monday, August 13, 2018 11:47 AM
    Monday, August 13, 2018 11:46 AM