locked
IIS 7.5 displaying plain text html upon web host (local) RRS feed

  • Question

  • User-1557173817 posted

    Hello just hosted my webmatrix application (cshtml) on iis 7.5 but getiing plain text html, dont know what to do.

    Friday, September 18, 2015 5:10 AM

Answers

  • User-1980594115 posted

    I experienced this in the past. I reinstalled ASP.NET version onto my server. And verified in IIS that that ASP.NET version was now in IIS. Also make sure that the DLLs are the valid Web Pages/WebMatrix version within BIN.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Monday, September 21, 2015 1:54 PM

All replies

  • User1313602441 posted
    I'm not sure I understand you.
    But do you mean the code is outputted in plain text by the browser?
    Or that the browser render part, but not all, of your code?
    And do note that when using WebMatrix, IIS is already preconfigured to host your Razor website.
    Saturday, September 19, 2015 7:28 AM
  • User-1980594115 posted

    I experienced this in the past. I reinstalled ASP.NET version onto my server. And verified in IIS that that ASP.NET version was now in IIS. Also make sure that the DLLs are the valid Web Pages/WebMatrix version within BIN.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Monday, September 21, 2015 1:54 PM
  • User379720387 posted

    Self hosting for development purposes is painful because you have to deal with all the configuration issues.

    I know from experience that after you got your site up and running, you will want to use WebDeploy to upload changes, and configuring Web Deploy is a whole other issue.

    Easiest is to find one of the free hosting companies that supports Webmatrix.

    Tuesday, September 22, 2015 2:03 PM