locked
VS2008 unit tests RRS feed

  • Question

  • Hi,

    I have Unit tests in VS2008 and the test configuration is set to generate Source Code Coverage, where I have selected all the referred assemblies. But when my tests finish executing, I just the code coverage for my unittest.dll and not the assemblies that are tested.

    Is there something that I am missing? I have verified that the tests do refer to code in the referred assemblies.

    I am using VS2008 Team Suite on 64 bit Windows 7 Enterprise

    Regards,

    Anubhav.


    • Edited by saxenark Wednesday, January 21, 2015 2:35 PM
    Wednesday, January 21, 2015 2:26 PM

Answers

  • Hi Anubhav,

    To make sure that whether you really refer to the assembly you want to test, I suggest you add a breakpoint in the class method you want to test, and then just debug your test method in your test project, if the breakpoint is not hit in class method, I think it would be your test method issue, for example, it doesn't class this class method or others.

    >>where I have selected all the referred assemblies.

    Do you make sure that you enable the dll file you want to collect code coverage? Maybe you forget to add it or add other dll file. You'd better remove and re-add it again. Please check the dll file path.

    Please also install the VS2008 SP1. 

    Best Regards,

    Jack


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Thursday, January 22, 2015 6:42 AM