locked
WACK Failed: The binary <appname>.exe is built in debug mode

    Question

  • My ARM version of my application has failed WACK. THe error messages states "The binary <appname>.exe is built in debug mode". I have checked my Visual Studio Configuration Settings and they are set to Release | ARM. The version of WACK is 3.3 the OS version is RT (6.3.9600.0). Im at a total loss why the WACK thinks I have built my app in debug mode. BTW I have just updated my Visual Studio to 12.0.30324.00 update 2 RC. Can anyone help?

    Thanks

    Ken

    Friday, April 25, 2014 9:33 PM

Answers

  • Hi James,

    On examining my project file I noticed this:

    <PropertyGroup Condition="'$(Configuration)|$(Platform)' == 'Release|ARM'">
        <OutputPath>bin\ARM\Release\</OutputPath>
        <DefineConstants>NETFX_CORE</DefineConstants>
        <Optimize>false</Optimize>
        <NoWarn>;2008</NoWarn>
        <DebugType>pdbonly</DebugType>
        <PlatformTarget>ARM</PlatformTarget>
        <UseVSHostingProcess>false</UseVSHostingProcess>
        <ErrorReport>prompt</ErrorReport>
        <Prefer32Bit>true</Prefer32Bit>
      </PropertyGroup>

    The Optimize was set to false. When. I set it to true, my arm version passed WACK. Thanks for bearing with me on this issue.

    Ken


    • Edited by KenCTSLTD Saturday, May 10, 2014 12:57 PM
    • Marked as answer by KenCTSLTD Saturday, May 10, 2014 12:58 PM
    Saturday, May 10, 2014 12:56 PM

All replies

  • Hi Ken,

    In the documentation, it said how to fix: Please make sure the app isn’t linking to any debug versions of a framework, and it is built with release configuration. If this is a managed app please make sure you have installed the correct version of .NET framework.

    So you have to validate at least three things:

    1, Your app did not ref to debug version of framework.

    2, Set the app debug configuration setting as "release"

    3, If you are working with Windows RT, you should use RT version of WACK.

    If the problem still exist, plz feedback to me.

    Thanks.

    --James


    <THE CONTENT IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, WHETHER EXPRESS OR IMPLIED>
    Thanks
    MSDN Community Support

    Please remember to "Mark as Answer" the responses that resolved your issue. It is a common way to recognize those who have helped you, and makes it easier for other visitors to find the resolution later.


    Monday, April 28, 2014 6:06 AM
    Moderator
  • Thanks James,

    I have checked the following:-

    Your app did not ref to debug version of framework : Using the same code base I have successfully deployed my application to the store for the x86 and x64 platforms.

    Set the app debug configuration setting as "release" : I have set the configuration to "release" for build and package creation ('ARM | Release').

    If you are working with Windows RT, you should use RT version of WACK: I have uninstalled and reinstalled WACK for RT.

    I'm still getting the same WACK failure. Is there any more information I can provide you with?

    Ken

    Wednesday, April 30, 2014 7:24 AM
  • I am making no headway on my issue, so If I don't hear from anyone in the next week or so I'll will have to bin my ARM version of my application.  In my app I'm using PRISM and Bing Maps, however as I mentioned before the x86/x64 versions are up in the store,

    I have tried a small test app and it passed WACK. So I can only presume somewhere in my project a reference of some sort is causing the WACK failure.

    K

    Wednesday, May 7, 2014 6:47 AM
  • Hi KenCTSLTD,

    Well, I try my best and I consulted with our senior engineers this morning and it seems your release package still contain some debug symbols. I cannot confirm without your project file (.csproj), would you share it with me?

    --James


    <THE CONTENT IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, WHETHER EXPRESS OR IMPLIED>
    Thanks
    MSDN Community Support

    Please remember to "Mark as Answer" the responses that resolved your issue. It is a common way to recognize those who have helped you, and makes it easier for other visitors to find the resolution later.

    Thursday, May 8, 2014 2:11 AM
    Moderator
  • Hi James,

    On examining my project file I noticed this:

    <PropertyGroup Condition="'$(Configuration)|$(Platform)' == 'Release|ARM'">
        <OutputPath>bin\ARM\Release\</OutputPath>
        <DefineConstants>NETFX_CORE</DefineConstants>
        <Optimize>false</Optimize>
        <NoWarn>;2008</NoWarn>
        <DebugType>pdbonly</DebugType>
        <PlatformTarget>ARM</PlatformTarget>
        <UseVSHostingProcess>false</UseVSHostingProcess>
        <ErrorReport>prompt</ErrorReport>
        <Prefer32Bit>true</Prefer32Bit>
      </PropertyGroup>

    The Optimize was set to false. When. I set it to true, my arm version passed WACK. Thanks for bearing with me on this issue.

    Ken


    • Edited by KenCTSLTD Saturday, May 10, 2014 12:57 PM
    • Marked as answer by KenCTSLTD Saturday, May 10, 2014 12:58 PM
    Saturday, May 10, 2014 12:56 PM