none
Microsoft Kinect Audio Control - Driver Installed but not starting up? Any ideas why? RRS feed

Answers

All replies

  • I'm not 100% sure what would be causing this, but we can try to narrow it down.

    From the programming guide (http://research.microsoft.com/en-us/um/redmond/projects/kinectsdk/docs/ProgrammingGuide_KinectSDK.docx), under "To verify the driver installation" section you'll find the following:

    1.    You should see a blinking green LED on the Kinect sensor. [when it's plugged into PC USB and connected to power]

    2.    In Device Manager in Control Panel, look for the following nodes under Microsoft Kinect:

    ·         Microsoft Kinect Audio Array Control

    ·         Microsoft Kinect Camera

    ·         Microsoft Kinect Device

    3.    Under Sound, Video and Game Controllers in Device Manager, the Kinect sensor's microphone array should appear

    ·         Kinect USB Audio

    Are any of these things different for you than as expected in guide? If so, let me know how they're different. Also,

    • Do you have multiple USB devices (in particular webcams or other Kinect devices) plugged in to the same USB controller as the Kinect? If so, try plugging the kinect by itself to the front of PC and the other devices to the back of PC (or vice versa) and see if that works for you.
    • Did you have a kinect driver previously installed? If so, you will need to uninstall it.

    If neither of these are true, please share as much information about your machine setup (make, model, OS version, peripherals connected, etc.) as you are comfortable sharing

    Hope something helps,
    Eddy


    I'm here to help
    Friday, June 17, 2011 1:59 AM
  • Hey Eddy-

    Thanks for the help, the famous just try and do a reboot did the trick!

    However, now the ShapeGame isn't working, it just seems to crash right when I see the word Shapes!

    Any ideas on that one?

    AMB

    Friday, June 17, 2011 2:18 AM
  • How does the application crash? Can you copy/paste exception stack or at least the name of exception?

     

    Thanks!
    Eddy


    I'm here to help
    Friday, June 17, 2011 3:03 AM
  • Hey Eddy-

    Another reboot fixed it, weird. It's working great now, very cool.

     

    AMB

    Friday, June 17, 2011 3:14 AM
  • Very strange that it needed 2 reboots. I'll pray to the gods of randomness tonight.

    BTW, I'm marking your post about how reboot fixed problems as an answer.

     

    Cheers,
    Eddy


    I'm here to help
    Friday, June 17, 2011 3:17 AM
  • Hi,

     

    I have been getting a very similar problem but with the Kinect Camera driver, not the Audio.

    I did install onto a different machine with no troubles so I am sure the Kinect is fine.

    I also get

    This device cannot start. (Code 10) as the device status.

    I've tried rebooting a few times. But still no joy. I have not been connecting directly to the machine but through a USB port located on a docking station. I am using a Toshiba M780 tablet PC with a docking station.

     

    I will connect directly to the machine and then reboot to see if that helps.

     

    I will try to post my results here later.

     

    I also have detailed screenshots if anyone is interested in the feedback. Just let me know who to send them to.

     

    Thanks

     

    Austin

     

     

     

     

     

    Friday, June 17, 2011 4:22 AM
  • My solution was to connect the Kinect directly to the machine. Not via the usb ports on the docking station or the usb hubs I have connected to my machine.

     

    After connecting the Kinect directly to the machine I required to reboot my machine to get all three drivers to show up as working in the device manager.

     

    I hope this helps!

    • Edited by Austin Dimmer Friday, June 17, 2011 4:36 AM Additional info
    Friday, June 17, 2011 4:34 AM