none
Implement ActiveSync client question: switch protocol versions between commands in a session communication with Exchange Server. RRS feed

  • Question

  • We're trying to implement an activeSync client.

    If we only want some capabilities of ActiveSync 12.0 such as: HTML-Email, Autodiscover. Can we just implement those 2 features using 12.0 and implement the rest commands using ActiveSync 2.5? Can we switch protocol versions between commands if server can support both?
    Wednesday, December 10, 2008 6:20 AM

Answers

  • Tony, 

    A server can support multiple versions of the protocol. A client can use whichever version deemed appropriate. Keep in mind that the ActiveSync protocol version 12.1 supports versions 12.0 and 2.5. It is recommended that you use the latest version. However, a client cannot switch between versions.

    Dominic Salemno
    SENIOR SUPPORT ESCALATION ENGINEER

    Monday, December 22, 2008 9:46 PM

All replies

  • Hello Tony,

    Thank you for your questions.  Someone from our group will respond to you soon.

    Regards,
    Mark Miller, US-CSS DSC PROTOCOL TEAM

    Wednesday, December 10, 2008 5:48 PM
  • Tony,

    Great question let me ask development to see if this is a supported. 
    Developer Consultant
    Thursday, December 11, 2008 4:36 PM
    Moderator
  • Tony, 

    A server can support multiple versions of the protocol. A client can use whichever version deemed appropriate. Keep in mind that the ActiveSync protocol version 12.1 supports versions 12.0 and 2.5. It is recommended that you use the latest version. However, a client cannot switch between versions.

    Dominic Salemno
    SENIOR SUPPORT ESCALATION ENGINEER

    Monday, December 22, 2008 9:46 PM