The following forum(s) have migrated to Microsoft Q&A (Preview): Azure DevTest Labs!
Visit Microsoft Q&A (Preview) to post new questions.

Learn More

 locked
Environment will not create for new users until they restart browser. RRS feed

  • Question

  • I have several DevTest Labs set up that are all showing the same issue.

    The Labs are set up using ARM template 'bases' that create an environment for the Lab User consisting of a virtual network and multiple VMs.

    Whenever I grant a new user permissions (Lab User permission normally) and they try to create a new environment, they click the Add button, choose the base (the only one available is the base I have created - I've turned off all the public bases), and enter an environment name, the UI takes them back to the main Lab screen, but the lab never gets created. They can do this multiple times, and the lab creation process will never start.

    However if they then close the browser, reopen it and do exactly the same steps again, the lab creates fine, and will continue to do so from that point onward.

    They have to completely close the browser, just closing the browser tab will not fix the issue. This problem happens across Edge, Firefox and Chrome so it's not browser specific, and it's happened to many users across multiple DevTest labs.

    I assume it's a bug of some sort in the Azure DevTest Labs UI.

    Has anyone else seen this issue?

    Wednesday, June 19, 2019 10:29 AM

All replies

  • Hi Mark,

    Thanks for reaching out! To investigate this further, can you please help us with the below details:

    1. What is the ARM template that you are using as your base?

    2. Where have you checked in your template?

    3. After assigning the permissions to a new user, have you tried doing a refresh and creating an environment?

    Friday, June 21, 2019 12:14 PM
    Moderator
  • Hi Mark,

    I tried reproducing this issue but the environment creation went fine for me.

    Assigned a new user the "DevTest labs user" permissions and created an environment using that new user.

    The environment was created successfully.

    We would be happy to assist in case to you still facing this issue :)

    Thursday, June 27, 2019 10:35 AM
    Moderator