none
Cannot load project targeting .NET Framework 4.0 when .NET Framework 4.5 is installed

    Question

  • Hi there,

    I have Visual Studio 2013 Community and I try to load a project targeting .NET Framework 4.0. When I do this, I get the following message:

    The C# project is targeting ".Net Framework, Version =v4.0",which is not installed on this machine. To proceed, select an option below.

    1. Change the target to .Net Framework 4.0. You can change back to ".Net Framework, Version=v4.0" at later time.
    2. Download the targeting pack for ".Net Framework, Version=v4.0". The project will not change.
    3. Do not load the project

    I have 3 options, none of which work:

    1) The first option tells me to change the project framework, which I can't do, as the project has to target .NET 4.0 for compatibility reasons.

    2) If I download and try to install .NET Framework 4.0, it doesn't work, as it says a newer version of .NET Framework is installed (4.5) and the installer doesn't continue. I can't uninstall .NET 4.5 either, because I use it for other projects.

    3) NO Comment

    Does anyone have a solution for this? That is, to be able to load/use both .NET 4.0 and 4.5 projects?

    Thanks

    • Moved by Kristin Xie Friday, February 19, 2016 5:34 AM VS related
    Thursday, February 18, 2016 2:09 PM

Answers

All replies