locked
'Microsoft.ACE.OLEDB.12.0' provider not working in 64 bit Windows 10 and office 2016 RRS feed

  • Question

  • How to fix the error "The 'Microsoft.ACE.OLEDB.12.0' provider is not registered on the local machine." on Windows 10 64 bit PC, 64 bit Office 2016.
    I am receiving this error when I try to import .xlsx thru "SQL Server Import and Export Wizard" and also thru SSIS.
    I've installed 64 bit ACE Provider and still getting the same error.

    Any help is highly appreciated.

    Thanks



    Thursday, October 31, 2019 4:45 PM

Answers

All replies

  • Hi jambaii,

    • There are two versions of the "SQL Server Import and Export Wizard": 32-bit and 64-bit.
      Please try to run one or another to see if it is working.
    • To see if the 'Microsoft.ACE.OLEDB.12.0' provider 64-bit is installed, just run the following in SSMS:

    -- 0. Check what 64-bit OLEDB providers are installed
    -- Microsoft.ACE.OLEDB.12.0 or
    -- Microsoft.ACE.OLEDB.15.0 or 16.0
    EXEC master.sys.sp_MSset_oledb_prop;

    Thursday, October 31, 2019 5:06 PM
  • Thanks Yitzhak,

    The 64 bit of "SQL Server Import and Export Wizard": works fine.
    How to get this done in thru SSIS.

    When I run EXEC master.sys.sp_MSset_oledb_prop, I see Microsoft.ACE.OLEDB.12.0 in there.

    Thank you



    • Edited by jambaii Thursday, October 31, 2019 5:33 PM
    Thursday, October 31, 2019 5:10 PM
  • Hi jambaii,

    So you can launch the "SQL Server Import and Export Wizard" wizard 64-bit.

    SSIS will work fine with the  'Microsoft.ACE.OLEDB.12.0' provider 64-bit.


    Thursday, October 31, 2019 5:32 PM
  • Hi Yitzhak,

    I am getting the below error when I run the SSIS Package.

    Error at Data Flow Task: There were errors during task validation.

    Error at Package3 [Connection manager "XLSX CnMgr"]: The requested OLE DB provider Microsoft.ACE.OLEDB.12.0 is not registered. If the 32-bit driver is not installed, run the package in 64-bit mode. Error code: 0x00000000.
    An OLE DB record is available.  Source: "Microsoft OLE DB Service Components"  Hresult: 0x80040154  Description: "Class not registered".

    Error at Package3 [Connection manager "XLSX CnMgr"]: The 'Microsoft.ACE.OLEDB.12.0' provider is not registered on the local machine. For more information, see http://go.microsoft.com/fwlink/?LinkId=219816


    Thursday, October 31, 2019 5:57 PM
  • Hi jambaii,

    You need to set the Run64Runtime to false. That setting is just for the Visual Studio (VS) in development environment, and won't affect the run-time environment on the server where you have 64-bit both for the OS and Microsoft ACE Provider.

    I recently answered a similar question.

    Check it out here: Excel Source stopped working in SSIS

    • Edited by Yitzhak Khabinsky Thursday, October 31, 2019 6:22 PM
    • Marked as answer by jambaii Wednesday, November 13, 2019 7:59 PM
    Thursday, October 31, 2019 6:19 PM
  • Hi jambaii,

    Please download 32 bit ACE Provider, then install it.

    The following links will be helpful:

    Best Regards,

    Mona



    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Friday, November 1, 2019 6:54 AM