none
COM1 is unusable if machine boots with cable connected RRS feed

  • General discussion

  • I am developing an application that receives data from a device over COM1 (note: this is not a development question)

    If I boot the (Windows 8.1) machine with the cable connected to the device, the application cannot open the COM1 port ("Access Denied"), which means something else is using the port. The app's not the culprit: PuTTY cannot open the port either.

    I cannot find with Process Explorer who is using the port (searched for "COM1" and "Serial").

    What can I disable in the OS to prevent "something" from "detecting" the presence of "some device" on COM1 at boot time?

    Sunday, March 15, 2015 5:47 AM

All replies

  • did you enable kernel debugging? if so, the kernel debugger can claim the port. does the port show up in device manager?

    d -- This posting is provided "AS IS" with no warranties, and confers no rights.

    Sunday, March 15, 2015 6:14 AM
  • No, I haven't enabled kernel debugging.

    Yes, the port does show up in device manager

    Sunday, March 15, 2015 7:23 AM
  • Just tried Putty run as admin: same "access denied" error
    Sunday, March 15, 2015 6:18 PM
  • yes.... (???)

    Sunday, March 15, 2015 8:36 PM
  • In my experience, Windows sometimes misdetects a GPS receiver as a serial mouse, preventing applications from opening the port. If that's what happened to you, the instructions in KB283063 should help.

    Thursday, March 19, 2015 10:15 PM
  • In this case the device attached to the com port is the other machine, thru the cross cable.

    Are you sure the cable is good for windbg? Used it before with other machines?

    -- pa

    Friday, March 20, 2015 1:05 AM
  • The other end of the cable is not connected to a PC, but to a custom device that sends data continuously (only GND and TX are connected)

    (FWIW: that device serves as the interface to my home's electronic electricity meter, which sends information about energy consumption)

    Friday, March 20, 2015 10:19 AM
  • Yep, it reports a "Microsoft Serial Mouse" is dangling there...

    The "disable" trick from https://support.microsoft.com/en-us/kb/283063 works like a charm.

    Thx for the help!

    • Edited by sba923 Saturday, March 21, 2015 7:30 AM
    Saturday, March 21, 2015 7:00 AM
  • The "disable" workaround saved my day.

    Thx for the help.

    P.S. The explanation for the SkipEnumerations vakue seems particulary obscure to me...

    Saturday, March 21, 2015 7:31 AM