locked
Data smart tasks disabled RRS feed

  • Question

  • Main development XP machine died so I got a new XP machine, installed SQL Server 2005 and VS 2005 Pro, and copied my files.

     

    Projects in new VS 2005 work except the Data Sources pane won't refresh and won't show all my data sources for an existing project (from the old machine.)

     

    Error: " An exception occurred while trying to update the data smart tasks, they will be disabled. Key not valid for use in specified state."

     

    Any ideas

     

    Update: I cannot even add a new data source to a brand new project.  This is VS 2005 from my MSDN subscription.

     

    Thursday, January 24, 2008 11:47 PM

Answers

  • I deleted C:\Documents and Settings\username\Application Data\Microsoft\Visual Studio\8.0\Server Explorer\DefaultView.SEView and everything works fine.

     

    Friday, January 25, 2008 10:03 PM

All replies

  • I deleted C:\Documents and Settings\username\Application Data\Microsoft\Visual Studio\8.0\Server Explorer\DefaultView.SEView and everything works fine.

     

    Friday, January 25, 2008 10:03 PM
  • I had a similar problem with my projects, I could not do anything with my datasources or datasets, not even after starting a new project.

     

    I even went as far as trying to uninstall everything and reinstalling it all!  However this did not help at all.

     

    The problem I had was a database listed in the ‘Database Explorer’ (for express 2005/2008 users) / ‘Server Explorer’ (studio users) was a broken link.

     

    All I did was to remove the database on the explorer from the ‘Database Explorer’ (this dose not affect your projects).  You don’t even have a project open to remove the database.

     

    After removing it, everything worked perfectly.

     

    I hope this works for you too.

     

    Regards,

    Richard Huish

    Monday, February 4, 2008 12:14 PM
  •  tombranagh wrote:
    I deleted C:\Documents and Settings\username\Application Data\Microsoft\Visual Studio\8.0\Server Explorer\DefaultView.SEView and everything works fine.

     

     

    I'm glad that you found another way to solve the problem, yes that would have the same effect as deleting all the databases/data-sources from the explorer.  Shame the error messages produces where so vague.

     

    Regards,

    Richard Huish

    Monday, February 4, 2008 12:18 PM
  • Hi Guys, thank you very much.  I had a similar problem, and resolved by using your suggestion.

    Question for you all: Were you using any 3rd party components etc in your projects while you had this problem? I had never such problem before until I was forced to use the ‘Infragistics’ Version8 (the newest one).   I usually only use .NET standard components, and have used VS2005/C# for more than 3 years (started from its beta version).  I just wonder if it is caused by the 3rd party software.

     

    Mubin Z

     

    Tuesday, April 15, 2008 2:48 PM
  • Thanks. Works also for VS2008! I was having issues with Right Click on Dataset not bringin up the context menu.

    You need to change to C:\Documents and Settings\username\Application Data\Microsoft\Visual Studio\9.0\Server Explorer\DefaultView.SEView plus you need to take ownership of Application Data folder in Windows 7 otherwise I could not access it.

    I would like to know why does this happen though? And how the hell did you find that solution? :P



    • Edited by kuklei Friday, April 27, 2012 3:07 PM
    Friday, April 27, 2012 3:03 PM