locked
VS 2010 Premium Editor is not showing red underlines on code errors ? RRS feed

  • Question

  • Hi,

    I have installed VS 2010 Premium. While typing on errors it is not showing any red underlines , as usually VS editor does. Like when you forgot to mention the ';' at the end of C# code line.. it shows red underline at the end of code line.

    I have tried this command "devenv /resetsettings"

     But my issue is still not resolved. Any suggestions please ?

    Thanks.

    • Moved by Brittany Behrens Tuesday, April 20, 2010 1:35 AM (From:Visual Studio Editor)
    Friday, April 16, 2010 9:33 AM

Answers

  • In my version the options you'd want are:

    Text Editor\C#\Advanced -> Underline errors in the editor and Show live semantic errors

    If you don't enable the second option then you won't see any errors until you compile.

    Michael Taylor - 4/20/2010
    http://msmvps.com/blogs/p3net

    • Marked as answer by Harry Zhu Friday, April 23, 2010 1:39 AM
    Tuesday, April 20, 2010 1:48 PM
    Moderator

All replies

  • VS > Tools > Options > Text Editor > C# > Advanced > Refracting >
    check the option called "warn if build errors exists...." and "warn on members ....."
    Tuesday, April 20, 2010 6:46 AM
  • In my version the options you'd want are:

    Text Editor\C#\Advanced -> Underline errors in the editor and Show live semantic errors

    If you don't enable the second option then you won't see any errors until you compile.

    Michael Taylor - 4/20/2010
    http://msmvps.com/blogs/p3net

    • Marked as answer by Harry Zhu Friday, April 23, 2010 1:39 AM
    Tuesday, April 20, 2010 1:48 PM
    Moderator