none
Unable to launch the IIS Express web server

    Question

  • Running VS 2015 just randomly started getting this message yesterday when trying to start any web project.  Old projects, new fresh projects, nothing starts iis express.  Been digging through every stack overflow discussion for the last 2 days and still nothing working.  Uninstalled iis express and reinstalled, same problem.  Uninstalled and reinstalled visual studio completely, same problem.  

    Tried everything from here:

    http://stackoverflow.com/questions/15873126/unable-to-launch-the-iis-express-web-server

    and here:

    http://stackoverflow.com/questions/18454751/unable-to-launch-the-iis-express-web-server-error

    When tracing with process explorer the correct command is running:

    "C:\Program Files (x86)\IIS Express\iisexpress.exe"  /config:"C:\dev\fuqthis\.vs\config\applicationhost.config" /site:"MyProject" /apppool:"Clr4IntegratedAppPool"

    I've tried deleting the .vs\config directory and it gets recreated with the appropriate <site> element.  In event viewer there is an error: 

    The worker process for app pool 'Clr4IntegratedAppPool', PID='1536', failed to initialize the http.sys communication when asked to start processing http requests and therefore will be considered ill by W3SVC and terminated.  The data field contains the error number.

    I've gone through the steps for event 2269 as detailed here:

    http://social.technet.microsoft.com/wiki/contents/articles/21750.event-id-2269-iis-worker-process-availability.aspx

    But still, no progress.

    When running the iisexpress command with the same parameters plus /trace:error it gives no more information:

    C:\>"C:\Program Files (x86)\IIS Express\iisexpress.exe"  /config:"C:\dev\fuqthis
    \.vs\config\applicationhost.config" /site:"MyProject" /apppool:"Clr4Integra
    tedAppPool" /trace:error
    Starting IIS Express ...
    Initializing the W3 Server Started CTC = 1088855
    W3 Server initializing WinSock.  CTC = 1088871
    W3 Server WinSock initialized.  CTC = 1088871
    W3 Server ThreadPool initialized (ipm has signalled).  CTC = 1088871
    Start listenerChannel http:0
    Error (rc=800700c1) in UlInitialize. Exiting
    Error initializing ULATQ.  hr = 800700c1
    Terminating W3_SERVER object
    InitComplete event signalled
    Process Model Shutdown called
    Unable to start iisexpress.

    For more information about the error, run iisexpress.exe with the tracing switch
     enabled (/trace:error).

    Wednesday, January 27, 2016 7:51 AM

Answers

  • Hi svickers,

    According to your description, this problem start from yesterday, it works fine before. Please check whether do installed some Visual Studio/Windows updates based on the update date in Control Panel -> Programs and Features -> Installed Updates. Please try uninstall the updates one by one to make sure which one causes this problem.

    In addition, please close all third part software when running Visual Studio, such as antivirus, which often causes all kinds of strange questions.

    Then please check the ActiveLog.xml under the path of %AppData%\Microsoft\VisualStudio\14.0. This file will log all operations when you operate Visual Studio.

    Best Regards,
    Weiwei

    Thursday, January 28, 2016 5:56 AM
    Moderator