none
Accessing ISA08 Values in Orchestration RRS feed

  • Question

  • Hello,

    I have a 835 EDI file. In the orchestration I am trying to access the ISA08 value.

    I am reading the value as varISA08 = Inbound835(EDI.ISA08);

    when I build the code I get below errors 

    Error 102 identifier 'ISA08' does not exist in 'MDSS.Biztalk.EDI'; are you missing an assembly reference?

    Error 103 cannot find symbol 'EDI.ISA08'Error 104 'ISA08': must be a message property of message 'Inbound835


    I am able to to override values when building some 270 files and similarly I am trying to read values when reading some EDI 835 documents.

    BaseArtifacts DLL is referenced in the project.

    Is there anything I need to set on Pipelines may be?


    Krishna

    Monday, October 15, 2012 2:39 PM

Answers

  • Hi Krishna,

    Implemented scenario which you explain and its working fine

    CODE:
    varISA08 = MessageIn(EDI.ISA08);
    System.Diagnostics.EventLog.WriteEntry("EDI ORCH",varISA08);

    Output : US.

    As you said you are getting error in building the project. Remove BaseArtifacts dll reference. And add it again .

    Assembly Microsoft.BizTalk.Edi.BaseArtifacts C:\Program Files (x86)\Microsoft BizTalk Server 2010\Microsoft.BizTalk.Edi.BaseArtifacts.dll

    Make sure referecne is correct try to rebuild the project. It should work.

    Pipeline and agreement come into after deployement.

    Let me know if still facinf same issue

    Thursday, October 18, 2012 9:18 AM

All replies

  • Which Pipeline You are using ?

    Tuesday, October 16, 2012 8:39 AM
  • EDI Recieve pipeline

    Krishna

    Wednesday, October 17, 2012 2:00 PM
  • EDi Receive Pipeline

    Krishna

    Wednesday, October 17, 2012 2:19 PM
  • Hi Krishna,

    Implemented scenario which you explain and its working fine

    CODE:
    varISA08 = MessageIn(EDI.ISA08);
    System.Diagnostics.EventLog.WriteEntry("EDI ORCH",varISA08);

    Output : US.

    As you said you are getting error in building the project. Remove BaseArtifacts dll reference. And add it again .

    Assembly Microsoft.BizTalk.Edi.BaseArtifacts C:\Program Files (x86)\Microsoft BizTalk Server 2010\Microsoft.BizTalk.Edi.BaseArtifacts.dll

    Make sure referecne is correct try to rebuild the project. It should work.

    Pipeline and agreement come into after deployement.

    Let me know if still facinf same issue

    Thursday, October 18, 2012 9:18 AM