none
installing .net 4.5.2 on Windows 8.1 machine RRS feed

  • Question

  • [7/18/2014, 14:20:17]

    Getting an error trying to install 4.5.2 on a Windows 8.1 machine.  User is an administrator, UAC is turned off.  installation pack is Run as administrator.  Attached is the end of error log.

    -----------------

    Starting install of item '.NET Framework 4.5.2' at tickCount = 1471671
    [7/18/2014, 14:20:35]evaluating IsPresent:
    [7/18/2014, 14:20:35]returning false
    [7/18/2014, 14:20:35]evaluating IsPresent:
    [7/18/2014, 14:20:35]returning false
    [7/18/2014, 14:20:36]WM_ACTIVATEAPP: Focus stealer's windows WAS visible, NOT taking back focus
    [7/18/2014, 14:20:53]WM_ACTIVATEAPP: Focus stealer's windows WAS visible, NOT taking back focus
    [7/18/2014, 14:19:59]calling PerformAction on an installing performer

    [7/18/2014, 14:19:59] Action: Performing actions on all Items...

    [7/18/2014, 14:19:59] Restart Manager: Detecting applications holding files in use....

    [7/18/2014, 14:20:3]SQL Server (MSSQLSERVER) : Service : Name = MSSQLSERVER : PID = 4608 : Session = 0 : Can restart : Friendly Name = SQL Server (MSSQLSERVER)
    [7/18/2014, 14:20:3]SQL Server Agent (MSSQLSERVER) : Service : Name = SQLSERVERAGENT : PID = 4424 : Session = 0 : Can restart : Friendly Name = SQL Server Agent (MSSQLSERVER)
    [7/18/2014, 14:20:3]SQL Server (CADSDE) : Service : Name = MSSQL$CADSDE : PID = 5292 : Session = 0 : Can restart : Friendly Name = SQL Server (CADSDE)
    [7/18/2014, 14:20:3]Net.Tcp Listener Adapter : Service : Name = NetTcpActivator : PID = 4136 : Session = 0 : Can restart : Friendly Name = Net.Tcp Listener Adapter
    [7/18/2014, 14:20:3]Net.Tcp Port Sharing Service : Service : Name = NetTcpPortSharing : PID = 4136 : Session = 0 : Can restart : Friendly Name = Net.Tcp Port Sharing Service
    [7/18/2014, 14:20:3]SQL Server Reporting Services (MSSQLSERVER) : Service : Name = ReportServer : PID = 2196 : Session = 0 : Can restart : Friendly Name = SQL Server Reporting Services (MSSQLSERVER)
    [7/18/2014, 14:20:3]Net.Pipe Listener Adapter : Service : Name = NetPipeActivator : PID = 3300 : Session = 0 : Can restart : Friendly Name = Net.Pipe Listener Adapter
    [7/18/2014, 14:20:3]Will show restart manager dialog.
    [7/18/2014, 14:20:6]User chose to close applications.

    [7/18/2014, 14:20:17] Restart Manager complete

    [7/18/2014, 14:20:17]Wait for Item (SetupUtility.exe) to be available
    [7/18/2014, 14:20:17]SetupUtility.exe is now available to install
    [7/18/2014, 14:20:17]Creating new Performer for Exe item
    [7/18/2014, 14:20:17]Created new ExePerformer for Exe item

    [7/18/2014, 14:20:17] Action: Performing Action on Exe at C:\b6f2a2b3b92bbef178ca60703beae5\SetupUtility.exe...

    [7/18/2014, 14:20:17]Launching CreateProcess with command line = SetupUtility.exe /aupause
    [7/18/2014, 14:20:17]Exe log file(s) :
    [7/18/2014, 14:20:17]C:\Users\ees911\AppData\Local\Temp\dd_SetupUtility.txt
    [7/18/2014, 14:20:17]Log File C:\Users\ees911\AppData\Local\Temp\dd_SetupUtility.txt exists and will be added to the Watson upload list
    [7/18/2014, 14:20:17]Exe (C:\b6f2a2b3b92bbef178ca60703beae5\SetupUtility.exe) succeeded.
    [7/18/2014, 14:20:17]Exe Log File: dd_SetupUtility.txt

    [7/18/2014, 14:20:17] Action complete

    [7/18/2014, 14:20:17]Error 0 is mapped to Custom Error:
    [7/18/2014, 14:20:17]Wait for Item (SetupUtility.exe) to be available
    [7/18/2014, 14:20:17]SetupUtility.exe is now available to install
    [7/18/2014, 14:20:17]Creating new Performer for Exe item
    [7/18/2014, 14:20:17]Created new ExePerformer for Exe item

    [7/18/2014, 14:20:17] Action: Performing Action on Exe at C:\b6f2a2b3b92bbef178ca60703beae5\SetupUtility.exe...

    [7/18/2014, 14:20:17]Launching CreateProcess with command line = SetupUtility.exe /screboot
    [7/18/2014, 14:20:17]Exe log file(s) :
    [7/18/2014, 14:20:17]C:\Users\ees911\AppData\Local\Temp\dd_SetupUtility.txt
    [7/18/2014, 14:20:17]Log File C:\Users\ees911\AppData\Local\Temp\dd_SetupUtility.txt exists and will be added to the Watson upload list
    [7/18/2014, 14:20:17]Exe (C:\b6f2a2b3b92bbef178ca60703beae5\SetupUtility.exe) succeeded.
    [7/18/2014, 14:20:17]Exe Log File: dd_SetupUtility.txt

    [7/18/2014, 14:20:17] Action complete

    [7/18/2014, 14:20:17]Error 0 is mapped to Custom Error:
    [7/18/2014, 14:20:17]Wait for Item (x64-Windows8.1-KB2934520-x64.msu) to be available
    [7/18/2014, 14:20:17]x64-Windows8.1-KB2934520-x64.msu is now available to install
    [7/18/2014, 14:20:17]Creating new Performer for Exe item
    [7/18/2014, 14:20:17]Created new ExePerformer for Exe item
    [7/18/2014, 14:20:17]WU Service was already enabled or was running
    [7/18/2014, 14:20:17]WU Service: EnsureWUServiceIsNotDisabled succeeded

    [7/18/2014, 14:20:17] Action: Performing Action on Exe at C:\b6f2a2b3b92bbef178ca60703beae5\x64-Windows8.1-KB2934520-x64.msu...

    [7/18/2014, 14:20:17]Launching CreateProcess with command line = wusa.exe "C:\b6f2a2b3b92bbef178ca60703beae5\x64-Windows8.1-KB2934520-x64.msu" /quiet /norestart
    [7/18/2014, 14:20:35]Exe log file(s) :
    [7/18/2014, 14:20:35]C:\Windows\logs\cbs\CBS.log
    [7/18/2014, 14:20:35]Log File C:\Windows\logs\cbs\CBS.log exists and will be added to the Watson upload list
    [7/18/2014, 14:20:35]Exe (C:\b6f2a2b3b92bbef178ca60703beae5\x64-Windows8.1-KB2934520-x64.msu) failed with 0x3f9 - The system has attempted to load or restore a file into the registry, but the specified file is not in a registry file format. .
    [7/18/2014, 14:20:35]Exe Log File: CBS.log
    [7/18/2014, 14:20:35]PerformOperation on exe returned exit code 1017 (translates to HRESULT = 0x3f9)

    [7/18/2014, 14:20:35] Action complete

    [7/18/2014, 14:20:35]Error 0x3f9 is mapped to Custom Error:
    [7/18/2014, 14:20:35]OnFailureBehavior for this item is to Rollback.

    [7/18/2014, 14:20:35] Action: Performing actions on all Items...

    [7/18/2014, 14:20:35]Restart manager will not be used since the current operation is not install.

    [7/18/2014, 14:20:35] Action complete

    [7/18/2014, 14:20:35] Action complete

    [7/18/2014, 14:20:54]Final Result: Installation failed with error code: (0x000003F9), "The system has attempted to load or restore a file into the registry, but the specified file is not in a registry file format. " (Elapsed time: 0 00:01:03).
    [7/18/2014, 14:21:11]WM_ACTIVATEAPP: Focus stealer's windows WAS visible, NOT taking back focus

    Friday, July 18, 2014 6:33 PM

Answers

All replies

  • sorry, filename I am running is NDP452-KB2901907-x86-x64-AllOS-ENU.exe
    • Marked as answer by shageman0304 Sunday, July 20, 2014 4:32 PM
    Friday, July 18, 2014 6:35 PM
  • hi shageman0304,

    Although you've marked your reply as the answer. I'm not so sure of your problem and solution to this issue. Please make sure you've choosed the right file to install.

    Regards,



    Barry
    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Monday, July 21, 2014 6:38 AM
    Moderator
  • Barry,

    Thanks for checking, I used every installer available for 4.5.2.  Offline, online and developer.  Each kept throwing the error message above.  There is no excuse for why the 4.5.2 would behave in such a bizarre fashion.

    I had to have the laptop out of the door this morning.  I reinstalled 8.1 and no problems installing 4.5.2.

    Monday, July 21, 2014 12:26 PM
  • @shageman0304,

    Thank you for share the result back.

    Regards,



    Barry
    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Tuesday, July 22, 2014 1:17 AM
    Moderator
  • Hi shageman0304,

    I'm also facing same error while installing .NET 4.5.2 silently from our installer framework on Windows 2012 and Windows 2012 R2 , but its intermittent issue.  We are using following command line.

    NDP452-KB2901907-x86-x64-AllOS-ENU.exe -pipe MySectionName /q /norestart

    Running same command line from command prompt works well.

    What solution you tried for this issue?

    Thanks,

    DBorse


     


    Wednesday, November 19, 2014 5:54 AM