locked
Does the Live Player fail on code with multi-dim. arrays? [iOS] RRS feed

  • Question

  • User329898 posted

    Dear folks, These are my first steps with Xamarin, C# and even Visual Studio. It might be incredibly stupid. I am trying to create my first application by following the current Xamarin University series. I'm trying to use the TicTacToe sample code provided by Jesse Dietrichson. It works like a charm when running as a UWP, but fails on the live player for iOS. I always get a

    Visualization Error Constructor on type 'System.Int32[]' not found (MissingMethodException)

    error when 2-dimensional integer arrays are created. It also affects multi-dimensional arrays of other types. When removing all code that somehow deals with dynamic arrays, it works fine. Can somebody reproduce this? I'm not sure if I'm just doing something horribly wrong. I haven't had a chance to compile a "real" iOS application as I only have a Mac at work, not at home.

    Many thanks for your time.

    Sunday, June 11, 2017 12:29 PM

Answers

  • User37696 posted

    Hi @Fronzel_Neekburm,

    Thanks for finding this issue! You can report bugs for the Live Player here: https://bugzilla.xamarin.com/enter_bug.cgi?product=Live%20Player

    • Marked as answer by Anonymous Thursday, June 3, 2021 12:00 AM
    Tuesday, June 20, 2017 1:52 PM

All replies

  • User112311 posted

    Hey. The LivePlayer is in early preview right now. A lot of stuff is still broken on it. If basic, non platform specific stuff like that works on one platform, chances are it's fine and will work on other platforms as well.

    I can't tell for sure from your description, but I'd guess the problem is in the live player, not your code.

    I advise you to stick to UWP / Android for now, which you can easily run natively / emulate on your Windows machine. Once you have access to a Mac, you can include iOS testing/debugging as well.

    Hopefully the live player gets better and more stable soon, so we can all benefit from it.

    Monday, June 12, 2017 10:20 AM
  • User329898 posted

    Many thanks for your reply.

    The Live Player is what got me hooked in the first place. I find the whole concept highly impressive and fascinating.

    It's good to know that the error is most probably caused by the Live Player itself. Do you think I should file a bug? If yes, where?

    Monday, June 12, 2017 8:13 PM
  • User37696 posted

    Hi @Fronzel_Neekburm,

    Thanks for finding this issue! You can report bugs for the Live Player here: https://bugzilla.xamarin.com/enter_bug.cgi?product=Live%20Player

    • Marked as answer by Anonymous Thursday, June 3, 2021 12:00 AM
    Tuesday, June 20, 2017 1:52 PM