none
Problem to connect

    Question

  • Hi,

    How to resolve this

    but relevant database is existing within the server and there is "RDP Port : 33333" existing to the server.


    Many Thanks & Best Regards, Hua Min

    Monday, February 27, 2017 8:12 AM

All replies

  • Monday, February 27, 2017 8:22 AM
    Moderator
  • Hi,

    Try adding the port number along with the server/instance. Like 10.123.12.23\isdev,1433

    You can find the port number in the configuration manager and several other places, refer here https://sqlandme.com/2013/05/01/sql-server-finding-tcp-port-number-sql-instance-is-listening-on/

    Monday, February 27, 2017 8:31 AM
  • Any other advice to this issue below?


    Many Thanks & Best Regards, Hua Min

    Monday, February 27, 2017 9:32 AM
  • 1. Make sure SQL Server Service is running
    2. If a named instance, make sure SQL Server browser service is running
    3. Make sure SQL Server is configured to allow remote connections
    4. Examine the SQL Server error log for messages confirming that SQL is listening on the expected network interfaces and ports
    5. Test server connectivity with PING from the client machine
    6. Test port connectivity using TELNET or PowerShell to the server and port (from step 4) from the client machine.  For example
    a. TELNET <server-name> 1433
    b. PowerShell: 1433 | % { echo ((new-object Net.Sockets.TcpClient).Connect("YourServerName",$_)) "server listening on TCP port $_" }
    7. Check firewall settings if step 5 or 6 connectivity test fails

    Best Regards,Uri Dimant SQL Server MVP, http://sqlblog.com/blogs/uri_dimant/

    MS SQL optimization: MS SQL Development and Optimization
    MS SQL Consulting: Large scale of database and data cleansing
    Remote DBA Services: Improves MS SQL Database Performance
    SQL Server Integration Services: Business Intelligence

    Monday, February 27, 2017 9:39 AM
    Answerer
  • Connection timeout on pre-Login often means SQL Server is to busy to handle the login request. Check CPU workload of SQL Server.

    Olaf Helper

    [ Blog] [ Xing] [ MVP]

    Monday, February 27, 2017 9:41 AM
    Moderator
  • Sorry, I still get this

     

    Many Thanks & Best Regards, Hua Min

    Tuesday, February 28, 2017 5:13 AM
  • Hi HuaMin,

    Are you able to connect to the target SQL Server with same connection string using SQL Server Management Studio?

    Firstly, please check that if your DNS record is wrong, for more details about checking DNS, see:https://gallery.technet.microsoft.com/Check-DNS-Server-and-DNS-887ef37b.

    Also I would recommend you check if your SQL Server is listening on static port 33333 in SQL Server Configuration Manager,  then enter “IP, port number” or “machinename, port number” in Server Name textbox and check if it is successful.

    Thanks,
    Lydia Zhang


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.



    Tuesday, February 28, 2017 6:03 AM
    Moderator
  • Hi,

    I think this is your first installation of SQL where you install the SQL with Windows Authentication, after installation you are trying to connect with sa.

    if I am correct then please login with windows Authentication 

    1. right click on Server propertise

    2. select Security

    3. Check the server authentication (if the Option is in Window Authentication  Mode then change to SQL Server second option and save and restart the SQL Services.

    Then you connect with sa if you know the password orelse change the password for sa and connect.

    Hope this solve your issue.

    Many Thanks.


    Afzalkhan

    Tuesday, February 28, 2017 6:21 AM
  • I do enable port 33333, on the server, by creating Inbound/outbound rule on Firewall, but I still get

    TITLE: Connect to Server
    ------------------------------
    
    Cannot connect to 182.173.77.208,33333.
    
    ------------------------------
    ADDITIONAL INFORMATION:
    
    Connection Timeout Expired.  The timeout period elapsed while attempting to consume the pre-login handshake acknowledgement.  This could be because the pre-login handshake failed or the server was unable to respond back in time.  The duration spent while attempting to connect to this server was - [Pre-Login] initialization=0; handshake=15010;  (Microsoft SQL Server, Error: -2)
    
    For help, click: http://go.microsoft.com/fwlink?ProdName=Microsoft%20SQL%20Server&EvtSrc=MSSQLServer&EvtID=-2&LinkId=20476
    
    ------------------------------
    
    The wait operation timed out
    
    ------------------------------
    BUTTONS:
    
    OK
    ------------------------------
    


    when I put
    182.173.77.208,33333
    in SSMS to connect.

    Many Thanks & Best Regards, Hua Min

    Tuesday, February 28, 2017 7:23 AM
  • Hi HuaMin,

    Looks like that your SQL Server is busy. Is your SQL Server getting enough of the server’s memory? And is there any possibility that you can restart your SQL Server Service?

    Regards,
    Lydia Zhang

    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, February 28, 2017 9:35 AM
    Moderator
  • No, but at the same time, within the server, I was able to connect to that, by putting SERVERNAME\DBNAME, using one other SSMS session.

    Many Thanks & Best Regards, Hua Min



    • Edited by HuaMin Chen Tuesday, February 28, 2017 10:03 AM
    Tuesday, February 28, 2017 9:59 AM
  • Hi HuaMin,

    What do you mean that use other SSMS session? You use local SSMS to connect to SQL Server? Have you checked the SQL Server memory and DNS record?

    Regards,
    Lydia Zhang

    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Wednesday, March 01, 2017 9:11 AM
    Moderator
  • Hi,

    Yes, I use SSMS within the server and am able to connect to that by "Server_name\DB_name", and can connect to that fine. But why the problem arise, with "server IP, 33333"?


    Many Thanks & Best Regards, Hua Min


    • Edited by HuaMin Chen Thursday, March 02, 2017 3:10 AM
    Thursday, March 02, 2017 3:09 AM
  • Hi,

    Any help?


    Many Thanks & Best Regards, Hua Min

    Friday, March 03, 2017 4:05 AM
  • Hi HuaMin,

    In your original post, do you connect to remote SQL Server from Visual Studio? If so, how about using "ServerName\Instance Name" as ServerName in Visual Studio?

    Also do you check the memory of SQL Server as follows and DNS record? Please also post the screenshot about your configured port in SQL Server Configuration Manager.


    Thanks,
    Lydia Zhang

    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, March 06, 2017 9:29 AM
    Moderator
  • Thanks. Where to get DNS record within SQL server? Here is what I get

    What do you want to see, within SS configuration manager?

    Many Thanks & Best Regards, Hua Min

    Monday, March 06, 2017 3:16 PM
  • Hi HuaMin,

    Please review my previous post about checking DNS. Also we need to check your configured TCP/IP port in SQL Server Configuration Manager.

    Thanks,
    Lydia Zhang

    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, March 07, 2017 8:26 AM
    Moderator
  • Sorry, I cannot get into this.

    Many Thanks & Best Regards, Hua Min

    Tuesday, March 07, 2017 8:52 AM
  • Hi HuaMin,

    Remove dot from the link.

    https://gallery.technet.microsoft.com/Check-DNS-Server-and-DNS-887ef37b

    Regards,
    Lydia Zhang

    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, March 07, 2017 8:57 AM
    Moderator
  • Hi,
    Is it to check DNS ONLY IF there is on DNS server? I do not have any DNS server to my current SQL server setup.


    Many Thanks & Best Regards, Hua Min

    Tuesday, March 07, 2017 2:15 PM
  • Hi,

    Any other help?


    Many Thanks & Best Regards, Hua Min

    Tuesday, March 21, 2017 3:28 AM