none
Port is not timing-out RRS feed

  • Question

  • Hi, 

    I am dealing with a strange situation - an orchestration calls a web service through the solicit-response with the WCF-Custom, ba sicHttp binding. The sendTimeOut is 1 minute, receiveTimeOut is 00:10:00, that is 10 minutes. Instead of timing out after not receiving response from the service, the orchestration dehydrated, and the send port has been in Active state for well over 2 two-days already.

    Any idea why is it like this or I don't understand something?

    Update: An attempt to restart the host instance,hosting the orchestration and port handler, crashes Admin  Console. When you re-open the Admin Console, the host instance instead of being restarted, is in the "stopped" stated. This is BizTalk 2013 R2.

    Thanks, Sergei

     



    • Edited by fly2 Friday, October 31, 2014 5:47 PM
    Friday, October 31, 2014 5:18 PM

Answers

  • You need to check  the destination IIS setting  on the server hosting the web service . You need to make periodic recycling for an application pool. So that it will recycle the process after the time interval specified.

    Below is the steps

    1. Open Internet Information Services (IIS) Manager:

          If you are using Windows Server 2012 or Windows Server 2012 R2:
              On the taskbar, click Server Manager, click Tools, and then click Internet Information Services (IIS) Manager.
          If you are using Windows 8 or Windows 8.1:
              Hold down the Windows key, press the letter X, and then click Control Panel.
              Click Administrative Tools, and then double-click Internet Information Services (IIS) Manager.
          If you are using Windows Server 2008 or Windows Server 2008 R2:
              On the taskbar, click Start, point to Administrative Tools, and then click Internet Information Services (IIS) Manager.
          If you are using Windows Vista or Windows 7:
              On the taskbar, click Start, and then click Control Panel.
              Double-click Administrative Tools, and then double-click Internet Information Services (IIS) Manager.

      In the Connections pane, expand the server name, and then click Application Pools.
      In the Application Pools pane, select the application pool you want edit.
      In the Actions pane, click Recycling...
      On the Recycling Conditions page of the Edit Application Pool Recycling Settings Wizard, select at least one of the options in the Fixed Intervals section, type values into the appropriate text boxes, and then click Next.

      (Optional) On the Recycling Events to Log page of the Edit Application Pool Recycling Settings Wizard, select the configurable recycling events and run-time recycling events that you want IIS to send to the event log when they occur, and then click Finish.


      Also set  the shutdownTimeLimit and startupTimeLimit attributes for shutting down and starting the worker processes in the application pool

    Thanks

    Abhishek


    • Marked as answer by Angie Xu Thursday, November 6, 2014 1:37 AM
    Friday, October 31, 2014 7:19 PM

All replies

  • You need to check  the destination IIS setting  on the server hosting the web service . You need to make periodic recycling for an application pool. So that it will recycle the process after the time interval specified.

    Below is the steps

    1. Open Internet Information Services (IIS) Manager:

          If you are using Windows Server 2012 or Windows Server 2012 R2:
              On the taskbar, click Server Manager, click Tools, and then click Internet Information Services (IIS) Manager.
          If you are using Windows 8 or Windows 8.1:
              Hold down the Windows key, press the letter X, and then click Control Panel.
              Click Administrative Tools, and then double-click Internet Information Services (IIS) Manager.
          If you are using Windows Server 2008 or Windows Server 2008 R2:
              On the taskbar, click Start, point to Administrative Tools, and then click Internet Information Services (IIS) Manager.
          If you are using Windows Vista or Windows 7:
              On the taskbar, click Start, and then click Control Panel.
              Double-click Administrative Tools, and then double-click Internet Information Services (IIS) Manager.

      In the Connections pane, expand the server name, and then click Application Pools.
      In the Application Pools pane, select the application pool you want edit.
      In the Actions pane, click Recycling...
      On the Recycling Conditions page of the Edit Application Pool Recycling Settings Wizard, select at least one of the options in the Fixed Intervals section, type values into the appropriate text boxes, and then click Next.

      (Optional) On the Recycling Events to Log page of the Edit Application Pool Recycling Settings Wizard, select the configurable recycling events and run-time recycling events that you want IIS to send to the event log when they occur, and then click Finish.


      Also set  the shutdownTimeLimit and startupTimeLimit attributes for shutting down and starting the worker processes in the application pool

    Thanks

    Abhishek


    • Marked as answer by Angie Xu Thursday, November 6, 2014 1:37 AM
    Friday, October 31, 2014 7:19 PM
  • Thank you Abhishek. 

    Restarting IIS did help, but it still didn't explain the problem. I am expecting BizTalk to time out when not receiving response within the prescribed timeout, but in fact it keeps waiting and waiting. 

    Is this an expected behavior?

    Thanks!

    Friday, October 31, 2014 8:52 PM
  • Hi Sergi,

    It is expected behavior caused when IIS does not recycle its working thread . Its is because each request response port waits for a response from IIS and its responsibility of IIS to recycle the worker process so that  threads can be released .

    As been suggested above ,You need to tune IIS  for your scenario.

    Thanks
    Abhishek


    Saturday, November 1, 2014 6:59 AM