none
unable to open project '...setup.vddproj'

    Question

  • Hi everyone,

    I open a old project in Visual Studio 2008 express, it remained, unable to open project '...setup.vddproj', an error was found on line #1.

    What is the problem? how to fix it.

    Thank you!

    lyl

    Saturday, March 11, 2017 6:45 PM

Answers

  • Hi lyl,

    Sorry for that I couldn't provide the Email since it is the forum support.

    If possible, you could upload your project to the one drive, and share the link here. Of course, you could move the personal information in your project it has.

    In addition, like our previous discussions, my understanding is that actually your VS could create this kind of projects now, but the real issue is that you couldn't open it. So maybe it is not the VS IDE issue, the real issue is that how this project was created, for example, whether it requires other project files or others.

    Since this forum is to discuss the VS IDE, not the real Smart Device CAB project experts, I just could provide you the suggestions about how to make sure that it is not the VS IDE Environment issue:

    (1) Test it in other VS2008 Environment, if it still has this issue using different VS machines, I think it was not the VS IDE issue, it would be related to this specific project.

    (2) Maybe you could try to contact with the previous developer since he is much more familiar with this project. Even if it was not a solution, but I think it could help you resolve this issue much more easily now.

    (3) If you don't have other VS2008 machines, like my suggestion, if possible, you could share me a simple sample, I will test it in my side.

    Thanks,

    Jack


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    • Marked as answer by lyl123 Monday, March 27, 2017 9:36 PM
    Sunday, March 26, 2017 3:11 AM
    Moderator

All replies

  • Hi lyl,

    Which VS2008 Express version did you use, C# or Web or others?

    >>unable to open project '...setup.vddproj'

    Where did you get this project? We don't find the vddproj file, but as far as I know, it has the .vdproj file in VS2008, is it the setup project(.vdproj)?

    (1) I test it using my Express version, it doesn't have the setup project in default.

    (2) I also test it using the prof version, we could create it.

    So for this issue, if it is the .vdproj file, your VS express would have a limitation for this specific project type. You'd better use the high version. Actually the VS2008 was really old version, if possible, I suggest you use the VS2015 or VS2017 version like the Community version which supports this project type and it is free.

    If I have misunderstood this issue, please feel free to let me know.

    Best Regards,

    Jack


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, March 13, 2017 9:12 AM
    Moderator
  • Hi Jack,

    I am using VS2008 Express Professional Edition Version 9.0.21022.8 RTM, it includes VB,C#, C++, Web.

    The project was developed by a former developer who left several months ago, there was only one developer, so no one else knew the project.

    I don't know if it is a setup project, there is a folder which includes a file CbpLocalizerSetup, its type is Visual Studio for Devices Deployment Project (.vddproj). So I think it is a setup project, I just got it 2 days ago.

    I opened it in VS2015 Community Version 14.025431.01 Update 3, it did not support it. I installed VS2015 installer project extension, it still reminded Unsupported, One-way upgrade.

    When I insert a image here, the system asks me to confirm my account, I cannot insert the capture image.

    I do not know what is the problem. Need I install other extensions or configure somewhere?

    Thank you very much!

    Best regards,

    lyl

    Monday, March 13, 2017 4:20 PM
  • Hi lyl,

    I think I found the project type, it was the Smart Device CAB project.

    Reference:

    https://msdn.microsoft.com/en-us/library/zcebx8f8(v=vs.90).aspx

    In my VS2008 prof version with sp1, it has this project, but I didn't find it in Express version, so you could check your VS, and make sure that whether it really supports this project type.

    Best Regards,

    Jack


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, March 14, 2017 5:49 AM
    Moderator
  • Hi Jack,

    I open it in VS2008 Professional Edition Version 9.0.21022.8 RTM , it remained, unable to open project '...setup.vddproj', an error was found on line #1. This is the screenshot,

    This is the screenshot when I open cbplocalizersetup.vddproj with notepad++,

    What is the problem in line 1? how to fix it.

    Thank you!

    lyl

    Friday, March 17, 2017 1:10 PM
  • Hi lyl,

    Thanks for your friendly response.

    It seems that we don't use the same version(not the same version number), please install the VS2008 SP1, check it again.

    Just to make this issue clearly:

    Whether you could create a new Smart Device CAB project in your VS like the following screen shot?

    We have to make sure that it is not the VS Environment issue firstly.

    In addition, if you could create a new one, maybe you could add all project files or code to this new project, test it again. Or open .sln file directly in your solution folder, test it again.

    Actually this forum is to discuss the VS IDE, if it is related to the specific setup project, I suggest you post this issue to this forum which supports the setup and deployment issue:

    https://social.msdn.microsoft.com/Forums/windows/en-US/home?forum=winformssetup

    Of course, if your VS couldn't create a new one, we have to think about the VS IDE itself now.

    If I misunderstood this issue, please feel free to let me know.

    Sincerely,

    Jack


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, March 20, 2017 2:52 AM
    Moderator
  • Hi Jack,

    Do you think it is  possible to be successful if I try it in VS2008 SP1? Before I install VS2008 SP1, need I uninstall VS2008 Professional IDE, or install VS2008 SP1 directly?

    I can create a new Smart Device CAB project in my VS2008.

    Can I create a new empty one and copy every file into the new one?

    When I double clicked .sln file directly in your solution folder, it used VS2015 not VS2008. VS2015 reminded unsupport the project.

    Thank you!

    lyl


    • Edited by lyl123 Tuesday, March 21, 2017 7:56 PM modify
    Tuesday, March 21, 2017 6:02 PM
  • Hi lyl,

    Generally the Update package would resolve some IDE's feedbacks, so if possible, you can install the sp1 directly.

    >>Can I create a new empty one and copy every file into the new one?

    We could create a blank solution, and then add all projects' files to a new blank solution. But not the real setup and deployment experts even if we often use this way for general projects.

    >>When I double clicked .sln file directly in your solution folder, it used VS2015 not VS2008. VS2015 reminded unsupport the project.

    The VS2008 project was really old version, generally we couldn't merge it to VS2015 directly, maybe it has some compatibility issues, do you have a backup for this project? To open it using the VS2008, my understanding is that you could right click the .sln file, you could choose the "open with" option, and then select the VS2008 as the default tool.

    I also discuss other members who are familiar with the setup project, it seems that we would included the compiled project files to the setup package, whether it has the files in your project? Anyway, maybe you could share a simple sample, I will help you test it in my side even if this forum just discusses the VS IDE issue.

    Sincerely,

    Jack


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Wednesday, March 22, 2017 3:22 AM
    Moderator
  • Hi Jack,

    I installed sp1, nothing changed.

    I can try to create a blank solution, and then add all projects' files to a new blank solution. I don't know if it can work, because some setting can not be copied.

    When I right clicked the .sln file, I chose the "open with" option, but I could find the VS2008. I uninstalled VS2015, when I right clicked the .sln file, I chose the "open with" option, I could find the VS2008. And VS2008 didn't worked, I installed VS2015 professional again. The result did not change.

    >>we would included the compiled project files to the setup package, whether it has the files in your project?

    I do not know what files you said. I have a few files in the project. Can you give me your email address, I can send the project to you, like so, you can load and deploy it, you can understand better. My email: liang.yongli@gmail.com.

    Are you working in China, I am also a Chinese, but I am in Canada now.

    Thank you very much!

    Best regards,

    lyl


    • Edited by lyl123 Wednesday, March 22, 2017 7:26 PM add info
    Wednesday, March 22, 2017 7:23 PM
  • Hi lyl,

    Sorry for that I couldn't provide the Email since it is the forum support.

    If possible, you could upload your project to the one drive, and share the link here. Of course, you could move the personal information in your project it has.

    In addition, like our previous discussions, my understanding is that actually your VS could create this kind of projects now, but the real issue is that you couldn't open it. So maybe it is not the VS IDE issue, the real issue is that how this project was created, for example, whether it requires other project files or others.

    Since this forum is to discuss the VS IDE, not the real Smart Device CAB project experts, I just could provide you the suggestions about how to make sure that it is not the VS IDE Environment issue:

    (1) Test it in other VS2008 Environment, if it still has this issue using different VS machines, I think it was not the VS IDE issue, it would be related to this specific project.

    (2) Maybe you could try to contact with the previous developer since he is much more familiar with this project. Even if it was not a solution, but I think it could help you resolve this issue much more easily now.

    (3) If you don't have other VS2008 machines, like my suggestion, if possible, you could share me a simple sample, I will test it in my side.

    Thanks,

    Jack


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    • Marked as answer by lyl123 Monday, March 27, 2017 9:36 PM
    Sunday, March 26, 2017 3:11 AM
    Moderator
  • Hi Jack,

    Yes, it is not the VS IDE Environment issue.

    So I move the issue to other place.

    You gave me a lot of help.

    Thank you very much!

    Best regards,

    lyl

    Monday, March 27, 2017 9:36 PM