Identity and Access Tool cannot load STS metadata document RRS feed

  • Question

  • Hi

    When trying to load a STS metadata file by Identity and Access tool, I get an error said, ID1116 metadata download error: The remote server returned an error: (407) Proxy Authentication required.

    Can anyone shed me light to solve this issue?



    Thursday, January 30, 2014 1:27 AM


  • The Identity and Access Tool for Visual Studio 11 delivers a dramatically simplified development-time experience with the following highlights:

    • Using the new tool, you can develop using web applications project types and target IIS express.

    • Unlike with the blanket protection-only authentication, with the new tool, you can specify your local home realm discovery page/controller (or any other endpoint handling the authentication experience within your application) and WIF will configure all unauthenticated requests to go there, instead of redirecting them to the STS.

    • The tool includes a test Security Token Service (STS) which runs on your local machine when you launch a debug session. Therefore, you no longer need to create custom STS projects and tweak them in order to get the claims you need to test your applications. The claim types and values are fully customizable.

    • You can modify common settings directly via the tool’s UI, without the need to edit web.config.

    • You can establish federation with Active Directory Federation Services (AD FS) 2.0 (or other WS-Federation providers) in a single screen.

    • The tool leverages Windows Azure Access Control Service (ACS) capabilities with a simple list of checkboxes for all the identity providers that you want to use: Facebook, Google, Live ID, Yahoo!, any OpenID provider, and any WS-Federation provider. Select your identity providers, click OK, then F5, and both your application and ACS will be automatically configured and your test application will be ACS-aware.

    For your question, please check this article which menthion the steps: .


    Thursday, January 30, 2014 1:16 PM