none
Visual Studio Community 2015 Application Hang on Debug

    Question

  • Whenever I try to debug a program (I've only been using C++) Visual Studio freezes up and no output is shown. In the Event Viewer, it says there was an Application Hang and that the program devenv.exe stopped interacting with Windows and was closed.

    I've searched around and can't find an answer, anyone have any ideas as to why this is happening?

    Wednesday, November 11, 2015 8:25 PM

Answers

  • Hi Lokrikk,

    The firs, please confirm that your computer's CPU and Memory is enough, which are not in high utilization.

    Please create a new C++ project or other type project using Visual Studio Community 2015 to make sure this problem occurs with a specific project or all projects.

    If just for a specific project, please remove the suo file in solution folder which saves user settings for current solution. If it doesn't work, please create a new blank solution and remove the project to the new solution one by one to confirm which project causes this problem.

    If for all projects in Visual Studio 2015, please try with following steps to troubleshoot this problem.

    1. Run Visual Studio as Administrator.
    2. Run Visual Studio in safe mode with "Deven.exe /SafeMode" command to prevents all third-party VSPackages from loading when Visual Studio starts, thus ensuring stable execution.
    3. Close all third part software, such as antivirus software.
    4. Reset all settings through menu Tools -> Import and Export settings -> Reset all settings.
    5. Repair your Visual Studio through Control Panel -> Visual Studio Community 2015 -> Change -> Repair.

    In addition, please please collect the Visual Studio operations log with  /Log switch. It will help us collect all operations when we operate Visual Studio. The log file can be found at %APPDATA%\Microsoft\VisualStudio\Version\ActivityLog.xml

    Best Regards,
    Weiwei


    Thursday, November 12, 2015 5:13 AM
    Moderator

All replies

  • Hi Lokrikk,

    The firs, please confirm that your computer's CPU and Memory is enough, which are not in high utilization.

    Please create a new C++ project or other type project using Visual Studio Community 2015 to make sure this problem occurs with a specific project or all projects.

    If just for a specific project, please remove the suo file in solution folder which saves user settings for current solution. If it doesn't work, please create a new blank solution and remove the project to the new solution one by one to confirm which project causes this problem.

    If for all projects in Visual Studio 2015, please try with following steps to troubleshoot this problem.

    1. Run Visual Studio as Administrator.
    2. Run Visual Studio in safe mode with "Deven.exe /SafeMode" command to prevents all third-party VSPackages from loading when Visual Studio starts, thus ensuring stable execution.
    3. Close all third part software, such as antivirus software.
    4. Reset all settings through menu Tools -> Import and Export settings -> Reset all settings.
    5. Repair your Visual Studio through Control Panel -> Visual Studio Community 2015 -> Change -> Repair.

    In addition, please please collect the Visual Studio operations log with  /Log switch. It will help us collect all operations when we operate Visual Studio. The log file can be found at %APPDATA%\Microsoft\VisualStudio\Version\ActivityLog.xml

    Best Regards,
    Weiwei


    Thursday, November 12, 2015 5:13 AM
    Moderator
  • Dear Weiwei,

    Disabling my antivirus software did the trick. Thanks a lot!

    Lokrikk

    Friday, November 13, 2015 2:48 AM