locked
iphone simulator in webmatrix doesn't work RRS feed

  • Question

  • User-204006626 posted

    I am trying to use the iPhone simulator in WebMatrix (don't know version, but it was latest as of June 11, 2013). It seems like a slick simulator but it won't let me enter my URL to my local PC. When I try to enter my URL in the webmatrix URL textbox, it truncates from this:

    http://s-r9wp2cp/apps/manager/SitePages/m_landing.aspx

    to this:

    http://s-r9wp2cp:80

    Fine, so I guess it wants host:port only. But ultimately I need the full URL. When I try to paste the full url into the iphone address bar, it does something exasperating. I paste the full url into the address bar of the iphone simulator and it immediately and automatically changes my url into this;

    http://s-r9wp2cp/apps/manager/_layouts/mobile/mblwiki.aspx?Url=%2Fapps%2Fmanager%2FSitePages%2Fm%5Flanding%2Easpx

    This is a sharepoint 2010 site, locally. Why does it change my url out from under me? Why won't it simply accept my url and load the page? A different iphone simulator loads the page as expected without any funny business. A regular browser on my PC loads it fine as well. Why is the webmatrix iphone simulator not allowing me to enter the correct URL?

    Wednesday, June 12, 2013 10:53 AM

Answers

  • User-821857111 posted

    This forum is for questions about using WebMatrix to develop sites using the ASP.NET Web Pages framework. You should post your question to the WebMatrix IDE forum here: http://forums.iis.net/1166.aspx

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Wednesday, June 12, 2013 3:55 PM