none
AutoSharePointInstaller RRS feed

  • Question

  • Hi,

    I'm using AutoSharePointInstaller to do a simple provisioning of one WebApplication with one sitecollection

    every things runs with no errors but the sitecollection opens completly messed up (a bunch of icons)

    If I delete this sitecollection and create it with CA then I'm ok.

    What can be wrong with my AutoSPInstallerInput.xml file?

    Help is really appreciated.

    Thanks you so much,

    DD

    Note: My parametrization is like this:

    <WebApplications AddURLsToHOSTS="true">
            <WebApplication Name="Portal Home">
                <Type>Portal</Type>
                <ApplicationPool>portal.test</ApplicationPool>
                <Url>http://test.demo</Url>
                <Port>80</Port>
                <UseHostHeader>true</UseHostHeader>
                <AddURLToLocalIntranetZone>true</AddURLToLocalIntranetZone>
                <GrantCurrentUserFullControl>true</GrantCurrentUserFullControl>
                <UseClaims>true</UseClaims>
                <UseBasicAuthentication>false</UseBasicAuthentication>
                <UseOnlineWebPartCatalog>false</UseOnlineWebPartCatalog>
                <Database>
                    <Name>Content_Portal</Name>
                    <DBServer></DBServer>
                    <DBAlias Create="false">
                        <DBInstance></DBInstance>
                        <DBPort></DBPort>
                    </DBAlias>
                </Database>
                <ManagedPaths />
                <SiteCollections>
                    <SiteCollection siteUrl="http://test.demo/">
                        <Name>Test Home</Name>
                        <Description>Portal Home Site</Description>
                        <HostNamedSiteCollection>false</HostNamedSiteCollection>
                        <Owner>demo\administrator</Owner>
                        <CustomDatabase></CustomDatabase>
                        <SearchUrl>http://test.demo/search/pages</SearchUrl>
                        <Template>CMSPUBLISHING#0</Template>
                        <LCID>1033</LCID>
                        <Locale>en-us</Locale>
                        <Time24>false</Time24>
                    </SiteCollection>
                </SiteCollections>

    Tuesday, February 7, 2017 11:52 PM

Answers

  • Not an autospinstaller expert but you should try using different site templates and see if that makes difference. My guess is that home page for site is not properly getting created while using autospinstaller. Have you tried to wait for some time and/or iisreset once script is finished and then access the site?

    Thanks
    Mohit

    • Marked as answer by DevDiver Wednesday, February 8, 2017 12:16 PM
    Wednesday, February 8, 2017 5:25 AM

All replies

  • Not an autospinstaller expert but you should try using different site templates and see if that makes difference. My guess is that home page for site is not properly getting created while using autospinstaller. Have you tried to wait for some time and/or iisreset once script is finished and then access the site?

    Thanks
    Mohit

    • Marked as answer by DevDiver Wednesday, February 8, 2017 12:16 PM
    Wednesday, February 8, 2017 5:25 AM
  • Hi DevDiver,

    As I understand, CMSPUBLISHING#0 is designed to be used as a template for a sub site where Publishing Infrastructure enabled.

    So in this case, I suggest you can change the template to others like SPSPORTAL#0 to see if it works:

    	<SiteCollection siteUrl="http://portal.contoso.com">
                        <Name>Portal Home</Name>
                        <Description>Portal Home Site</Description>
                        <HostNamedSiteCollection>false</HostNamedSiteCollection>
                        <Owner></Owner>
                        <CustomDatabase></CustomDatabase>
                        <SearchUrl>http://portal.contoso.com/search</SearchUrl>
                        <Template>SPSPORTAL#0</Template>
                        <LCID>1033</LCID>
                        <Locale>en-us</Locale>
                        <Time24>false</Time24>
              </SiteCollection>

    Thanks

    Best Regards


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Wednesday, February 8, 2017 7:13 AM
  • Hi,

    I noticed that there is more than one publishing site template. I solved my issue using another template. ID 53 BLANKINTERNET and not ID 39 CMSPUBLISHING

    CMSPUBLISHING#0 Publishing Site
    BLANKINTERNET#0 Publishing Site

    Thank you guys

    Wednesday, February 8, 2017 12:20 PM
  • I'm happy to see your issue getting resolved. :)

    Thanks
    Mohit

    Wednesday, February 8, 2017 1:31 PM