locked
Need help connecting to Informix from VWD 2005 RRS feed

  • Question

  • User-740453238 posted

    I am trying to connect to an informix DB on a linux machine from my vwd 2005.  I have installed the IBM Informix client sdk 3.0 with the visual studio addins.  When I try to conenct using the IBM Informix Data Source I and do a test I get this error.

     Value Cannt be null.  Parameter name: Keyword. 

     If I click on the Advance button the Add Connection wizard closes down.

    If I try to use the Microsoft ODBC data source under Add Connection my Test returns OK.  But when I go to the Server Explorer windows and click on the + sign beside the Tables I get this error:

    ERROR [HY090][Informix][Informix ODBC Driver]Invalid string or buffer length.

    Does anyone have any ideal how to get this to work.  FYI I am running Informix SE version 7.26UC6R1 for Red Hat Enterprise Linux.

     I posted this in other databases but did not get any responses.

     

    Monday, April 20, 2009 9:00 AM

Answers

  • User1716267170 posted

    Where would I look for the null values?  The ODBC Driver woks fine from withing Access.

    Mike

    The problem may be caused by the datasource which is informix DB on the linux machine. If possible, you could connect it remotely and check whether there's any improper data e.g. null value. Also, please check the driver and see whether some options can be set to avoid the problem.

    P.S. if there's any forum discussing Informix DB, you could try asking there to get a better solution.

    Thanks.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Friday, April 24, 2009 2:36 AM

All replies

  • User1716267170 posted

    Hi mhinkle2,

    I guess it may be difficult for us to figure out the exact problem since we're not familiar with IBM Informix driver. From your description, I have two suggestions. 1) Please check whether some null values caused the problem which can be seen from error message. 2)You could check the document of informix driver and see whether you can find something useful.

    Thanks.

    Wednesday, April 22, 2009 10:32 PM
  • User-740453238 posted

    Where would I look for the null values?  The ODBC Driver woks fine from withing Access.

    Mike

    Thursday, April 23, 2009 9:38 AM
  • User1716267170 posted

    Where would I look for the null values?  The ODBC Driver woks fine from withing Access.

    Mike

    The problem may be caused by the datasource which is informix DB on the linux machine. If possible, you could connect it remotely and check whether there's any improper data e.g. null value. Also, please check the driver and see whether some options can be set to avoid the problem.

    P.S. if there's any forum discussing Informix DB, you could try asking there to get a better solution.

    Thanks.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Friday, April 24, 2009 2:36 AM