none
Updating to 4.1 update 1 RRS feed

  • Question

  • Hello,

     

    I think I am having some problems updating to EF 4.1 update 1.  I do the install and it says it completes but then DbModelBuilder's (I believe is only in 4.1) namespace can't be found.  Any ideas on why this is?  Or how I can fix this?

    Tuesday, September 27, 2011 8:16 PM

Answers

All replies

  •  

    Did you add a reference to the dll in the project to EntityFramework.dll?

     


    Fernando (MCSD)

    If a post answers your question, please click "Mark As Answer" on that post and "Mark as Helpful".
    Tuesday, September 27, 2011 8:34 PM
  • Hi Lavagin,

    update1 just includes a small set of changes, you can refer here: http://blogs.msdn.com/b/adonet/archive/2011/07/25/ef-4-1-update-1-released.aspx

    if you are using "EntityFramework NuGet package" to import the EntityFramework.dll, you should update in the preceding link.

    Have a nice day.


    Alan Chen[MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    • Marked as answer by Lavagin Thursday, September 29, 2011 12:55 PM
    Wednesday, September 28, 2011 7:44 AM
    Moderator
  • Hmm I guess (at least for me) the stand alone installer didn't properly install EF 4.1.  I used NuGet and now it seems to be working.  It does annoy me to no end that just about every update for every Microsoft product is always different.
    Thursday, September 29, 2011 12:55 PM