locked
O365 & Multi-Factor Auth (MFA) with the iOS Mail.app RRS feed

  • Question

  • O365 & Multi-Factor Auth (MFA) with the iOS Mail.app for Exchange email not accepting the Active Directory password. 

    Example:
    Currently some iOS 12/13 device, users who has been set up for MFA OTP in O365 (using the Authenticator code) are suddenly getting the prompt for exchange password. The AD password will not work. The apps password will work but of course we don't want to use this. 

    Azure sign in logs have error 50199 (same situation as this below.
    https://social.msdn.microsoft.com/Forums/en-US/a6833bc0-a2e0-4237-ab2c-96236182fcc7/mfa-on-iphone-131-stops-working-after-a-few-hours-error-code-50199-shown-in-azure-sign-in-log?forum=windowsazureactiveauthentication

    My environment:

    -All iOS devices are running iOS 12/13
    -We use Apple's iOS Mail.app (not the MS Outlook app).
    -Users can choose to use SMS or the MS Authenticator app for MFA.

    What could be the issue? No real answer in all the searches online.
    Pleas help. 
    Tuesday, January 21, 2020 10:09 PM

All replies

  • Hi pcdoctoday,

    We're migrating from MSDN to Microsoft Q&A as our new forums and Web Apps which is your question is more closely related to has already made the move!  In future, you can ask and look for the discussion for Azure Active Directory related questions here: https://docs.microsoft.com/answers/topics/azure-active-directory.html.
    We are actively working to onboard remaining Azure services on Microsoft Q&A and we will make a public announcement once complete. Want to Learn more about new platform: Microsoft Q&A Getting Started  


    Thanks in advance, Ryan

    Wednesday, January 22, 2020 6:13 PM
  • Hello pcdoctoday

    We have seen in the past for this to be an issue with the iOS app which we do not have control on . However some troubleshooting can be surely done on this on best effort basis to find out the exact reason. If this behaviour is consistent with all the users then we believe this to be  issue with the app however if that is not the case then it may have other issues. This may require deeper  troubleshooting and hence we would request you to send us an email on azcommunity[at]microsoft[dot]com referencing this thread and we will help you with alternate support options.

    Thank you. 


    Please take a moment to "Mark as Answer" and/or "Vote as Helpful" wherever applicable. Thanks!!

    Wednesday, January 22, 2020 6:39 PM
  • I would suggest not using app passwords anymore since you can use MFA on iOS 11. More secure but that's going to be the supported method or worked on method going forward. I like you used to use app passwords, but have switched over and it's been working well in my experience.
    Monday, January 27, 2020 5:04 AM